When menus go above menubar tab is drawn without bottom

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
minor
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: timeless, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({polish})

Trunk
Future
x86
All
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
2000052320 linux [there's no reason windows would behave better, but current 
win nightly shouldn't have passed smoketest and should be a blocker]
Move mozilla to very near bottom of screen. Click the Bookmark menu [you might 
also need to shrink the window, i'm not sure].

Behavior: The menu itself is rectangular and appears above a tab. It looks 
disjointed.
Requested: The tab should be upside down so that it seems to attach in the same 
fashion as for downward menus.

Top=Left; Bottom=Right.
Current Menu below Menu title:
([ |  |...| ]
Current Menu Above Menu title:
[ |  |...| ](
Requested:
[ |  |...| ])

Comment 1

18 years ago
Setting severity to minor, removing "~RFE" from summary, adding polish keyword.
This is a visual polish item only.

To see this the distance from the menubar to the bottom of the desktop must be
less that the height of at least one menu (Bookmarks is normally the tallest).
The menu then goes up, as expected, but the rounded tab around the menu name
stays at the top, so the tab has no bottom edge and an extra-thick top edge.

Attaching a screencap zeroing in on the problem.  CC-ing ben@netscape.com
in case this is more his area.
Severity: normal → minor
Keywords: polish
Summary: ~RFE When menus anchor above menuitems on menubar the tab is drawn down w/out bottom. → When menus go above menubar tab is drawn without bottom

Comment 2

18 years ago
Created attachment 9073 [details]
Screen capture showing menubar highlight tab; menu up
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M20

Comment 3

18 years ago
Mass-moving all M20-M30 XPToolkit bugs to Future
Target Milestone: M20 → Future
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
(Assignee)

Comment 5

18 years ago
*** Bug 43748 has been marked as a duplicate of this bug. ***
works in newer themes
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.