In <browser.js>, "Error: gPrefService is null"

VERIFIED FIXED in Firefox 3.5

Status

()

Firefox
General
P5
normal
VERIFIED FIXED
11 years ago
6 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({intermittent-failure})

3.0 Branch
Firefox 3.5
x86
Windows Server 2003
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [verified1.9.1.3 or before] )

(Reporter)

Description

11 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111605 Minefield/3.0b2pre] (nightly) (W2Ksp4)

1. Create new profile.
2. Set |javascript.options.showInConsole = true| in <about:config>.
3. Exit FF.

4. (Re)start FF with a parameter, like '-jsconsole' or '-profilemanager'.
5. Look at the Error Console.
5r.
[
Error: gPrefService is null
Source File: chrome://browser/content/browser.js
Line: 2556
]

But no error if no parameter...
Flags: blocking-firefox3?
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Priority: -- → P5
This might be the cause of the orange on WINNT 5.2 fxdbug-win32-tb Dep Debug + Leak Test

The error is:
 * Call to xpconnect wrapped JSObject produced this error:  *
  [Exception... "'[JavaScript Error: "gPrefService is null" {file: "chrome://browser/content/browser.js" line: 2561}]' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]

and the command line is:
cmd = /e/builds/tinderbox/Fx-Trunk-Memtest/WINNT_5.2_Depend/mozilla/obj-fx-trunk/dist/bin/firefox.exe -P default
(Reporter)

Updated

9 years ago
Blocks: 438871
Flags: wanted1.9.0.x?
OS: Windows 2000 → Windows Server 2003
Whiteboard: [orange]
This shouldn't be an issue on trunk.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 448572
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.5

Updated

9 years ago
Version: Trunk → 3.0 Branch
(Reporter)

Comment 5

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111605 Minefield/3.0b2pre] (nightly) (W2Ksp4)

I can still reproduce.
(Though I may need to use Enter on the profile manager once first and restart again!?
And maybe using a commandline parameter is not required...)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.14pre) Gecko/2009080105 GranParadiso/3.0.14pre] (nightly) (W2Ksp4)

Bug still there in 3.0.x:
{
Error: gPrefService is null
Source File: chrome://browser/content/browser.js
Line: 2518
}

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.3pre) Gecko/20090801 Shiretoko/3.5.3pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090801 Minefield/3.6a1pre] (nightly) (W2Ksp4)

V.Fixed, in 3.5.x/+.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Whiteboard: [orange] → [verified1.9.1.3 or before] [orange]
(Reporter)

Comment 6

9 years ago
Moved wanted1.9.0.x=? to bug 448572.
Flags: wanted1.9.0.x?
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [verified1.9.1.3 or before] [orange] → [verified1.9.1.3 or before]
You need to log in before you can comment on or make changes to this bug.