run-mozilla.sh should use "./" when launching moz executables

VERIFIED FIXED

Status

P4
minor
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: joel.reed, Assigned: cls)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
--- run-mozilla.sh~	Wed May 24 09:09:37 2000
the run-mozilla.sh script assumes that you have "." in PATH. to make script
more generic with less assumptions the following patch should be applied...

+++ run-mozilla.sh	Wed May 24 09:08:54 2000
@@ -60,7 +60,7 @@
 #
 cd ~/tmp/package
 cmdname=`basename $0`
-MOZ_APPRUNNER_NAME="mozilla-bin"
+MOZ_APPRUNNER_NAME="./mozilla-bin"
 MOZ_VIEWER_NAME="viewer"
 MOZ_DIST_BIN=""
 MOZ_PROGRAM=""
The normal way to run mozilla is with the "mozilla" script (and viewer with the
mozilla-viewer script), which calls run-mozilla.sh with the argument
"./mozilla".  I admit these defaults could be improved, but it's very low
priority.

Changing component to "Build Config" (since that seems the closest to what this
is) and reassigning, and confirming bug, and lowering priority/severity.

Perhaps, though, it would be better to make this clearer in the top of the
run-mozilla.sh script.

Also, in the patch above, viewer and mozilla-bin should both be changed (or
neither).
Assignee: asadotzler → cls
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → Build Config
Ever confirmed: true
Priority: P3 → P4
QA Contact: jelwell → granrose
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
Fix was checked in last week.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 3

19 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.