url-classifier tests never actually run on the unit test machines

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: reed, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-firefox3 -
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
From toolkit/components/url-classifier/Makefile.in :

  48 ifdef ENABLE_TESTS
  49 ifndef MOZ_ENABLE_LIBXUL
  50 TOOL_DIRS     += tests
  51 endif
  52 endif

We aren't running any of the tests? That seems really, really, really bad. What if there's a really bad bug which these tests would catch, but because we never actually run them, we don't know about the bug!

bsmedberg added this ifndef at 2007-05-23 06:24	with log message "Fix url-classifier+libxul warnings and test errors, r=luser (no bug)".
Flags: in-testsuite?
Flags: blocking-firefox3?

Comment 1

11 years ago
Is the unit-test machine building with libxul? That's probably not good, because there are a fair number of binary tests that are disabled (i.e. don't link correctly) with libxul.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Is the unit-test machine building with libxul? That's probably not good,
> because there are a fair number of binary tests that are disabled (i.e. don't
> link correctly) with libxul.

http://mxr.mozilla.org/mozilla/source/tools/buildbot-configs/testing/unittest/

I don't see --disable-libxul anywhere in those files, so most likely, they are building with libxul.
We should do this, but its more of a "we should do this today" than a blocker for release.
Flags: blocking-firefox3? → blocking-firefox3-

Comment 4

11 years ago
Any update on this?

Comment 5

11 years ago
I am nominating this for blocking since I think it's important to run these tests.  If someone can confirm that the tests are in fact still running, even with the ifndef, then I'm ok not blocking on this.
Flags: blocking-firefox3- → blocking-firefox3?
The tests aren't running on the machines which do our nightly builds, as the tests are incompatible with the build configuration that we ship - we don't want to modify the build configuration (as then we wouldn't be testing what we're shipping) but at the same time we don't want to not run these tests.

This bug calls for the tests to be runnable on nightly builds, which I don't think blocks.

OTOH, we need to make sure that we *do* run the tests on the bits we use for a release, so I'm cc'ing tony to ensure that the todo of "run url classifier tests" gets added to his testplan. Dave should be able to help QA figure out what they need to do there.
Flags: blocking-firefox3? → blocking-firefox3-

Updated

11 years ago
Depends on: 434234

Updated

10 years ago
Duplicate of this bug: 477245

Comment 8

10 years ago
Created attachment 360985 [details] [diff] [review]
enable xpcshell tests

We can at least enable the xpcshell tests.
Attachment #360985 - Flags: review?(ted.mielczarek)

Updated

10 years ago
Attachment #360985 - Flags: review?(tony)

Updated

10 years ago
Attachment #360985 - Flags: review?(tony) → review+

Comment 9

10 years ago
Comment on attachment 360985 [details] [diff] [review]
enable xpcshell tests

Yes.
Attachment #360985 - Flags: review?(ted.mielczarek) → review+

Comment 10

6 years ago
Looks like this was done elsewhere.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.