alarm/reminder not going off at specified time

RESOLVED WORKSFORME

Status

Calendar
Alarms
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: paul stanton, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8pre) Gecko/20071023 Sunbird/0.7

since upgrading to 0.7, reminders such as "45 minutes before" fails to fire at the desired time and then fires after the fact.

sorry if this is duplicate, i did search.

Reproducible: Sometimes
(Reporter)

Comment 1

10 years ago
Created attachment 289269 [details]
it should have fired already
Paul, we need your calendar exported as an ICS file to investigate what is happening. You can make your calendar data anonymous before attaching it to this bug report.

Comment 3

10 years ago
Same as bug 402085?

Comment 4

10 years ago
Paul, please export your calendar as an ICS file like Martin said.
(Reporter)

Comment 5

10 years ago
lol, there's no way i'm posting my personal calendar online and no way i have time to censor it. but here's the entry for one that fired at the wrong time:

BEGIN:VEVENT
CREATED:20080210T225330Z
LAST-MODIFIED:20080210T225431Z
DTSTAMP:20080211T044410Z
UID:93778b35-e41c-4a7a-95b0-744eea345bfb
SUMMARY:medical centre
DTSTART;TZID=/mozilla.org/20070129_1/Australia/Sydney:20080211T144500
DTEND;TZID=/mozilla.org/20070129_1/Australia/Sydney:20080211T154500
BEGIN:VALARM
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Mozilla Alarm: medical centre
ACTION:DISPLAY
END:VALARM
END:VEVENT

fired 61 minutes late.

Comment 6

10 years ago
I also encountered this problem (more generally, I can't tell if this is specific to any kind of event/task/whatever). It's just that frequently (about at least once a week, with about 10 events/week) the Alarm/Reminder goes off way (often hours) after the events occur. It even happens that the reminder appears with more than one event which are all in the past. As I always use the suspend mode of windows, I suspect the internal timing mechanism could get confused with that. I also don't think the calender component reacts to the resume event of windows, so that it could show all missed events instantly after the resume.
(I use Thunderbird 2.0.0.14 with Lightning 0.8 on Windows XP, but the same Problem occured with Sunbird for some versions before; I used it a few months with versions starting from 0.4 until at least 0.7).

Comment 7

10 years ago
(In reply to comment #6)
Probably Bug 357706 that is fixed for the next release.

Comment 8

10 years ago
Does this still happen with 0.9pre?

Comment 9

10 years ago
(In reply to comment #8)
> Does this still happen with 0.9pre?

It's hard to verify that the problem does not occur anymore, as it did not happen (at least for me) in a predictable way, but I observed my alarms since you posted the question and everything seems to be ok.
I think it would be good if the original bug reporter could also comment on this.
(Reporter)

Comment 10

10 years ago
response to #6 i've written java scheduling programs which work fine with windows resuming. once windows resumes, threads wake up as if the clock runs in super fast forward mode until it reaches the current time - as you'd hope. i don't think this is the cause of the problem.

i just did a quick test with a 5 minute reminder - at 12:24:59 i saved an event for 12:30 with a 5 min reminder. it fired on time (as soon as i saved it). then i updated the event to 12:35, still with a reminder at 5 min. it failed to fire at 12:30.

i've got an appointment this afternoon with a 45m reminder. i'll let you know if i miss the appointment because the reminder didn't fire! ;)
(Reporter)

Comment 11

10 years ago
my mistake in above comment (middle para) i stuffed that test up. i've re-done a similar test and it seems to work. i will report back if another reminder fails in the future.
(Reporter)

Comment 12

10 years ago
ok, my reminder for 1 hour before 345pm this afternoon just fired (at 1138pm). my computer may have been suspended at or shortly after 245pm, i can't remember.


problem not solved.
(Reporter)

Comment 13

10 years ago
sorry, in the above i was testing with the previous version.

haven't had a problem with yet 0.9

Comment 14

10 years ago
Resolving as WORKSFORME per previous comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.