Last Comment Bug 404471 - Duplicate "File" menu on Mac in German localization
: Duplicate "File" menu on Mac in German localization
Status: VERIFIED DUPLICATE of bug 385966
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 01:33 PST by Andreas Hartl
Modified: 2007-11-20 02:07 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andreas Hartl 2007-11-20 01:33:08 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

On Mac OS 10.5.1, Firefox 3.0b1 w/ German localization displays two "Datei" (aka File) menus:
* the first menu appears on the default location (next to the program identifier string "Firefox") and is fully functional.
* the second menu appears after the help menu. Some of its entries are disabled (greyed out) and none of the entries work.

Both menus' entries are displayed by the help search feature available in 10.5, e.g. "neues fenster" will bring up the entry of the first file menu as well as the corresponsing entry of the last entry.

Reproducible: Always

Steps to Reproduce:
1. Start the German locatization of Firefox on OS X 10.5.1


Expected Results:  
The second file menu should not be there
Comment 1 Jeremy Baron 2007-11-20 01:46:31 PST
Please see http://www.mozilla.com/en-US/firefox/3.0b1/releasenotes/#issues before filing bugs against Fx 3 beta 1

*** This bug has been marked as a duplicate of bug 385966 ***
Comment 2 Stephen Donner [:stephend] 2007-11-20 02:07:56 PST
Verified dup

Note You need to log in before you can comment on or make changes to this bug.