Closed Bug 404511 Opened 12 years ago Closed 12 years ago

Building without SVG fails

Categories

(Core :: Web Painting, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: atzaus, Assigned: jwatt)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111808 Firefox/3.0b2pre
Build Identifier: 

When building without SVG the build stops at
nsFrameFrame.cpp
e:/BuildDir/mozilla/layout/generic/nsFrameFrame.cpp(953) : error C2039: 'svg' : is not a member of 'nsGkAtoms'
        e:/BuildDir/mozilla/layout/generic/../../content/base/src\nsGkAtoms.h(49) : see declaration of 'nsGkAtoms'
e:/BuildDir/mozilla/layout/generic/nsFrameFrame.cpp(953) : error C2065: 'svg' : undeclared identifier

Using:

--disable-svg
--disable-canvas

VC++ 2008 RTM
MsSDK 6.1

Reproducible: Always
Blocks: 294086
Assignee: roc → jwatt
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bustage fix is checked in.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
nsLineLayout.cpp
e:/BuildDir/mozilla/layout/generic/nsLineLayout.cpp(763) : error C2039: 'svgOuterSVGFrame' : is not a member of 'nsGkAtoms'
        e:/BuildDir/mozilla/layout/generic/../../content/base/src\nsGkAtoms.h(49) : see declaration of 'nsGkAtoms'
e:/BuildDir/mozilla/layout/generic/nsLineLayout.cpp(763) : error C2065: 'svgOuterSVGFrame' : undeclared identifier
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404636
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The bustage as originally reported was fixed. The other bug covers the other issue.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.