Reword "save session" dialog box displayed on closing

RESOLVED WORKSFORME

Status

()

Firefox
General
--
enhancement
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112003 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112003 Minefield/3.0b2pre

I think better button names would make easier to users what is happening.

Reproducible: Always

Steps to Reproduce:
Open to tabs and try to exit Firefox.
Actual Results:  
Message:
Do you want Minefield to save your tabs for the next time it starts?

Buttons:
Save
Quit
Cancel

Expected Results:  
Message:
What do you want Minefield to do with your current session?

Buttons:
Save opened tabs
Don't save opened tabs
Cancel
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Moving to enhancements.  I do not agree with the suggested name changes, but I agree that the current names may be a little vague.  Perhaps "Yes", "No", "Cancel" would be better?

I will let someone else make that call.
Severity: minor → enhancement
Component: General → Session Restore
QA Contact: general → session.restore
(Reporter)

Comment 2

10 years ago
Yes/No/Cancel buttons are way too generic; giving more information inside the buttons lets the user work without reading what Firefox has to say, but understaing what it will do.
(Reporter)

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 3

10 years ago
Please, reconsider the wording of this bug, cause it is quite confusing every time I see it.

Comment 4

10 years ago
Summary changed.
Summary: Make Firefox quit question about opened tabs clear → Reword "save session" dialog box displayed on closing.
(Reporter)

Updated

10 years ago
Summary: Reword "save session" dialog box displayed on closing. → Reword "save session" dialog box displayed on closing

Comment 5

10 years ago
(In reply to comment #0)
> What do you want Minefield to do with your current session?

How's Joe User supposed to know in this situation what a "session" is? He'd rather want to hold on to his "tabs", wouldn't he?

> Save opened tabs
> Don't save opened tabs

These are currently worded as "Save and Quit" and just "Quit" which IMO summarize more to the point what'll happen when clicking the respective button.

Suggesting WONTFIX, but leaving the final say to a UI peer.
Component: Session Restore → General
QA Contact: session.restore → general
Whiteboard: [wontfix?]
(Reporter)

Comment 6

10 years ago
Updated proposal:

Message:
What do you want Minefield to do with your current tabs?

Buttons:
Save opened tabs
Don't save opened tabs
Cancel
(Reporter)

Comment 7

10 years ago
Note that saying just "Quit" does not mean the tabs won't be saved; and average Joe could rely on this.
Currently, button texts are "Save and Quit" - "Quit" - "Cancel". Instead of "Quit" Fx could have "Don't save and Quit". But your proposed text is actually too much long. I propose WONTFIX.
Currently, the question asked is "Do you want Minefield to save your tabs for the next time it starts?"

Since this is a simple yes or no question, I think simple yes and no buttons would suffice.  Perhaps rename cancel to "Don't Quit" or something like that.

If we keep the question as it is, I do not think YES and NO are too vague.  They answer the question directly.  Considering this, I would resolve this INVALID.
Majority of users are too much distract, and don't read the question. The additional text is an fillip to read the question.

"Cancel" is a very common button for every program, so it don't need additional text.

I don't understand why you would resolve this as INVALID. This is a bug that can be applied to Firefox, so it's certainly valid.
If they are really so distracted that they do not read the question, then I think they are going to be far too distracted to care about whether their tabs are saved or not.  If the majority of Firefox users are truly this distracted then why bother giving them a yes or no at all.  Just a quit/don't quit scenario and always save tabs.
(In reply to comment #11)
> If they are really so distracted that they do not read the question, then I
> think they are going to be far too distracted to care about whether their tabs
> are saved or not.  

?_? Because it's more user-friendly? ^__^

> If the majority of Firefox users are truly this distracted
> then why bother giving them a yes or no at all.  

Because you must select "Don't ask next time" if you don't want it bother you any more. So sooner or later you'll read the message. The button text is only something more, and I don't know the problem you have to see it ;-)
I am all for making things more user friendly.  The only problem I have is that it is very bad, from a design perspective to have buttons with a lot of text in them.  Ideally, you the buttons to have one or two words.

I have no problems with the concept you are suggesting.  I am merely stating that I believe it is fine the way it is and if you wish to improve upon it, then find the single words that capture what it is you want to do.

Otherwise, I would resolve this invalid until such time.
(Reporter)

Comment 14

10 years ago
Expected Results:  
Message:
What do you want Minefield to do with your current opened tabs?

Buttons:
Save
Don't save
Cancel

Does that make sense in English? :P
That makes sense to me and makes more sense than the current dialog.
I don't necessarily agree with WONTFIX.  We do need to get this reviewed however.
Component: General → Session Restore
QA Contact: general → session.restore

Updated

10 years ago
Component: Session Restore → General
Keywords: uiwanted
QA Contact: session.restore → general

Comment 17

9 years ago
According to 

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

, this seems to be resolved.  There is a question and concise buttons that works very well for me: 


"Do you want Firefox to save your tabs and windows for the next time it starts?"
[ ] Do not ask me next time
< Quit >             < Cancel >  < Save and Quit >
(Reporter)

Comment 18

9 years ago
Quit does not state that the tabs won't be saved. Plus, a Do... question has to be answered with Yes/No.

1. Do you want Firefox to save your tabs and windows for the next time it
starts?

Yes, No, Cancel

2. What do you want Firefox to do with your tabs and windows?

Save them, Don't save them, Cancel
(Reporter)

Comment 19

9 years ago
To make it clear: there's no difference between "Quit" and "Save and Quit". The difference is known if one assumes that Quit won't save the tabs/windows given that there exists a button for that. But then we should assume users read _all_ buttons, which I wouldn't do.

Comment 20

9 years ago
Good point.  I guess it's still a bug.
WFM, we don't seem to  have this dialog anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.