Closed Bug 404539 Opened 14 years ago Closed 14 years ago

jsDriver.pl -K fails to report errors

Categories

(Core :: JavaScript Engine, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bc, Assigned: bc)

Details

(Keywords: regression)

Attachments

(1 file)

From bug 404499 comment 2

I have not seen the regression because the driver does not report the failures
even if the output comes with errors:

~/m/trunk/mozilla/js/tests $ ./jsDriver.pl -e smdebug -l
js1_5/Regress/regress-168347.js -K
-#- Executing 1 test(s).
-#- Wrote results to 'results-2007-11-20-161256-smdebug.html'.
-#- 0 test(s) failed
Flags: in-testsuite-
Flags: in-litmus-
err, I meant -K didn't show the error but -R does. doh. 
Summary: jsDriver.pl -R fails to report errors → jsDriver.pl -K fails to report errors
The biggest issue for me is that the failure is not included into the list of failed test cases as I diff against such list to check for regressions. 
Attached patch patchSplinter Review
Igor, this should fix it.
Attachment #289500 - Flags: review?(igor)
Attachment #289500 - Flags: review?(igor) → review+
Checking in jsDriver.pl;
/cvsroot/mozilla/js/tests/jsDriver.pl,v  <--  jsDriver.pl
new revision: 1.73; previous revision: 1.72
done

Igor, I am really sorry this didn't work for you. The regression is entirely my fault.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: regression
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.