Adding an existing remote calendar (.ics) to Lightning fails (same calendar works in Sunbird).

VERIFIED DUPLICATE of bug 338527

Status

--
major
VERIFIED DUPLICATE of bug 338527
11 years ago
11 years ago

People

(Reporter: evan.bibbee, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 2007102304

I know that there is an existing bug out that is SIMILAR to this one, but not quite the same.  If I subscribe to an existing remote calendar, a calendar is created, but none of its events show up in Lightning.  Even after deselecting and reselecting the calendar to make sure it is indeed 'visible,' nothing!  Strangely, the SAME remote calendar file operates perfectly in Sunbird.  Hmmmm...

Reproducible: Always

Steps to Reproduce:
1.Start Thunderbird.
2.Create a new remote Calendar
3.Enter URL location for calendar
4.Name calendar
5.Calendar appears on calendar list, but no events appear.
Actual Results:  
Results as described.

Expected Results:  
Displayed calendar events stored in remote calendar.

Sunbird build used for comparison is 20071023.
What similar bug are you referring to?

What type of remote calendar do you try to create? Ics over http, ics over ftp, gdata, caldav, wcap, ...?

Do you use a Trunk (Lightning 0.6a1) or 1.8 Branch (Lightning 0.8pre) nightly build? What Thunderbird version?

Do you see any Lightning related error messages in the Error Console?
(Reporter)

Comment 2

11 years ago
I was referring to bug number 320362.  Like mine, it was only a problem in Lightning, not Sunbird.  However, in that bug, the new calendar subscription never even appears in the calendar list.  In mine, the calendar name and color appear in the central list, but its events do not.

I am using/creating ics over http.

I am using the latest stable release of Lightning (0.7) and Thunderbird version 2.0.0.9 (20071031).

Will get back to you on the error console.  I'll have to re-enable lightning and check.
(Reporter)

Comment 3

11 years ago
OK.  Here is what I see in console.  If the problem is something obvious, I apologize in advance for being more of a savvy end-user as opposed to a programmer.

Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///Users/bibbee/Library/Thunderbird/Profiles/2ashha9f.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js :: anonymous :: line 885"  data: no]
Source File: file:///Users/bibbee/Library/Thunderbird/Profiles/2ashha9f.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js
Line: 885
Could be a proxy related issue. See Bug 338527 for a similar error message. If your are using a proxy ensure that it is configured correctly in Thunderbird. Try manual proxy configuration if automatic proxy configuration is used.
(Reporter)

Comment 5

11 years ago
OK.  I am resoving the bug.  For some reason, my proxy configuration was switched to automatic in Lightning/Thunderbird even though I do not use a proxy.  How I do not know.

In Sunbird, it was always on "direct connection."  Once I changed to the same setting in T/L, everything worked as it should.  Sorry I didn't figure this out for myself, and thanks for the help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 338527
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.