Closed Bug 404636 Opened 12 years ago Closed 12 years ago

Building without SVG fails

Categories

(Core :: Web Painting, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9beta2

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

Attachments

(1 file, 2 obsolete files)

You need to #ifdef just the SVG line. the subDocumentFrame check needs to stay there.
Attached patch Minimal define (obsolete) — Splinter Review
Attachment #289618 - Flags: review?(roc)
Comment on attachment 289618 [details] [diff] [review]
Minimal define

This isn't the right patch.
Attachment #289618 - Attachment is obsolete: true
Attachment #289618 - Flags: review?(roc)
Attached patch Minimal define 2Splinter Review
Ups, previous attachment was the same....
Attachment #289619 - Flags: review?(roc)
Assignee: roc → romaxa
Attachment #289558 - Attachment is obsolete: true
Comment on attachment 289619 [details] [diff] [review]
Minimal define 2

Simple patch to allow building layout without SVG.
Attachment #289619 - Flags: approval1.9?
Keywords: checkin-needed
Please don't add checkin-needed until the patch has approval. All patches either need approval1.9+ or the bug must be blocking1.9+/blocking-firefox3+ in order to land.
Keywords: checkin-needed
Duplicate of this bug: 404511
Attachment #289619 - Flags: approval1.9? → approval1.9+
Checking in layout/generic/nsLineLayout.cpp;
/cvsroot/mozilla/layout/generic/nsLineLayout.cpp,v  <--  nsLineLayout.cpp
new revision: 3.285; previous revision: 3.284
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.