Memory usage balloons under general browsing in Firefox 3.0 beta1.

RESOLVED DUPLICATE of bug 404645

Status

()

Firefox
General
P2
critical
RESOLVED DUPLICATE of bug 404645
11 years ago
11 years ago

People

(Reporter: David Graham, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

It seems memory usage increases drastically after viewing a set number of sites. As of yet, I need to view no more than 10 webpages to produce the issue.

Reproducible: Always

Steps to Reproduce:
1. I view a certain number of pages
2. Memory usage ballons
3. Must exit with task manager.
Actual Results:  
A large amount of ram is consumed.

Expected Results:  
Memory usage should not have been that high.

Comment 1

11 years ago
How much memory are we talking about?  What sites?  How much memory does Firefox 2.0 use on the same sites?

Comment 2

11 years ago
Same happens to me.
- Two tabs; one blank tab, and one playing youtube or onionnews video.
- Memory jumps from 50-700k (keeps growing).
- Cpu jumps to 96-99% usuage.
- Video is stopped and high usage stays.
- Have to kill with task manager.

Firefox 2 with same actions:
- Memory stays around steady 100-130k memory.
- Cpu stays around 15-25% usage.
- After video is stopped, memory stops growing, and cpu goes down.
- Exits fine. 

Comment 3

11 years ago
Same goes for me but it isn't consistently triggered.

This occurred once when I loaded (yahoo and ftml.net) as my homepages and the behavior triggered upon opening firefox 3.0b1

Next time this occurred I had just browsed 2-3 sites (yahoo and ftml) then did a search and the cpu maxed out for 20 seconds and then stayed around 50-60% while memory just kept climbing. I had to kill with task manager since the time before when it happened I just power cycled the computer instead of waiting to recover.

I would test it more but it is such a catastrophic failure that I don't really want to use firefox 3.0b1 at this point.

(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> How much memory are we talking about?  What sites?  How much memory does
> Firefox 2.0 use on the same sites?
> 

I viewed digg followed by Facebook. Then, I went to IGN. I tried other sites I generally go to as well. It seems to occur after so many pages independent of the number of sites I visit and independent of the sites visited.  The memory amount continues to increase if I keep firefox open. The CPU usage will just spike up, and it will consume memory until I either run out of memory or exit through the task manager.
(Reporter)

Comment 5

11 years ago
In response to the last question, I currently have two of the sites I visited open in seperate tabs, and CPU usage is  < 1% with 155 MB of ram used.

Comment 6

11 years ago
From my experience, I don't think it is related to the number of sites visited. I was able to get this to occur with all extensions disabled, a fresh profile, and a single open website open. I then left the application alone. With 5 minutes the memory starting spiking, growing from its starting size of about 39MB to 800MB in a matter of seconds. Once I saw the spike begin, I switched the website to about:blank. This did nothing to stop the memory from rising. I have no doubt it would keep going if I had had more that 1GB of RAM total.

Updated

11 years ago
Duplicate of this bug: 404628

Comment 8

11 years ago
I was able to get this after opening to a blank page, and simply opening the "Help | About" menu or even just entering a single character into the address bar.

Eventually, instead of shutting down Firefox I left the computer alone for several minutes, when I returned memory usage had gone back down to normal and the problem has not yet reoccurred.
Need to find out what you guys have in common.  Is this similar to the hyperthreading issue on dual core cpus?

Having several reports of this on IRC as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?

Comment 10

11 years ago
I am also seeing this behavior.

1. I think this started happening on the 19th or 20th, using latest Nightly
2. I've been using Nightlies for months with no issue

So I spent some time today going back through previous Nightly builds:
1. Download Nightly from Mozilla FTP
2. Extract to a new directory on my filesystem
3. Delete \Application Data\Mozilla (the whole folder)
4. Launch firefox.exe from within previously mentioned folder
5. At the 'make Minefield your default browser' dialog I decline
6. Two tabs load. The 404-Page for this build of Minefield and the main Minefield page (tab #2)
7. Minimize Minefield and leave alone for 1-5 minutes.
8. CPU usage increases a bit (~30% ?) and memory usage goes from ~50MB to 600-800MB within 30 seconds after this whole process starts
9. Firefox can only be killed with the Task Manager

I can see this behavior by repeating the above steps except instead of letting Minefield sit there on the two default pages, I browse to Gmail/GReader. Same result.

A few minutes ago I logged out of Windows, came back in and downloaded the latest Nightly again, deleted my \Mozilla directory and started over. This time I got all the way through browsing to handfuls of pages, installing extensions, updating bookmarks (feeling happy). Then it happened again.

The Nightlies I tried were about 10 total, ranging from 10/10 to 11/20.

Windows XP SP3
AMD Athlon 64 3200+
1024MB RAM, 2x512

I'm going to try leaving Minefield open while this memory-usage issue is happening instead of killing it like comment #8 suggets. Will post my results.

Comment 11

11 years ago
I just tried letting Minefield run in this high-memory-usage state. The result is that it took 9 minutes for it to do exercise its demons but they went away. For now.

1. Watching a YouTube video
2. Minefield's CPU time goes up to 90+% for 15-30 seconds.
3. Memory usage starts rising. firefox.exe CPU usage between 5% and 40%.
4. Once memory usage maxes out (System at 99% of available 1024MB), firefox.exe CPU usage goes down. 
5. Memory usage stays at 95% or higher for 2-3 minutes. CPU usage flucates between 0% and 15% during this time.
6. Memory usage begins to lower. To 90%. Then back up to 99%. Back to 90%. The whole process took about 5-6 minutes and looked like this: 99% -> 90% -> 99% -> 90% -> 80% -> 99% -> 80% -> 99% -> 70% - > 60% -> 50% -> 40% -> 62MB. Each step took 10-30 seconds.

By the way, Minefield seems to be taking more CPU time than usual to load things like Gmail/Reader. Normal pages throw it up to 70% CPU usage (example: http://planet.mozilla.org/).

I've been using Minefield for 10 minutes now with no issues besides the above strangely high CPU usage. I will report back if the memory does its spike again.

Comment 12

11 years ago
WinXP SP2
Pentium 4 3.4GHz
1024MB RAM

I am working on finding the lowest needed steps.

1. Created a brand new profile.
2. Set the default page to be about:blank
3. Restarted FF.
4. Sometime within the first two minutes, the CPU went to 100% and memory use started to balloon.

As a side note, if I can get to it before the memory gets too high, the app will appear to close using the normal process, but the process keeps going and growing in the background.

If I can figure out how to, I am going to try to upload the graph window of the task manager during one of my runs.

Comment 13

11 years ago
Created attachment 289660 [details]
memory and CPU usage during failure

Comment 14

11 years ago
Ihave this one too.

Windows XP SP2
Duron 1GHz
1024MB ram

Starting up with about:blank and a fresh profile, it takes about 5 minutes for the memory use to explode. It gets up to about 845M, and then drops and rises again and then just sort of oscillates between 200M and 845M.

The time it takes to start the ballooning varies between tests (I just tried one that went up immediately). Using Firefox actively does seem to increase the probability.
cc'ing vlad and stuart - guys, can you take a look and see if you can repro the
STR and effect in comment 12, or give Jonathan some tools to investigate this
more thoroughly?

Blocking until we can get a resolution.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Possibly a dupe of / related to bug 404645.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404645
You need to log in before you can comment on or make changes to this bug.