Typical installation- Launches blank opening page

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: agracebush, Assigned: samir_bugzilla)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
steps to reproduce:
1. install build 2000052408
2. choose a profile or create a profile and launch

Actual result: opening page is blank
Expected result: (as obtained using netscape-mac-sea.bin file)- opening page is 
displayed - 'what's new' or home.netscape.com depending on which launch

Comment 1

19 years ago
This apparently happened only in the installer build.

I installed the other build from 2000052408, and when I launch Mozilla, it heads 
straight for http://www.mozilla.org.

Comment 2

19 years ago
mac.
Assignee: cls → jj

Comment 3

19 years ago
Grace, can you do a folder compare between installer and .sea using CodeWarrior 
IDE. this could show evidence of one -or more- missing files in the installer.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

19 years ago
jj,

In the files compare: there are 3 files in Installer build that are not in 
sea.bin build
However there are *many* files in sea.bin build that are not in Installer build- 
too many to copy here.  Most of them are .xpt files in the Components folder. 
Is there a way to make a copy of the diffs? 

Comment 5

19 years ago
Try to save the compare window from wihtin CodeWarrior. If disabled, all you have 
left is a screen shot (Cmd+Shift+4) + click in the window to capture.

Missing .xpt files in "Components" should be ok. In the Installer version, they 
all get merged into a single .xpt file per module (browser, mail, xpcom, nim, 
etc.)
missing .dtd, .xul, .rdf or properties files would be more problematic.

Comment 6

19 years ago
cathleen and sgehani spent a lot of time yesterday looking into this and found 
urlhistory.xpt or something like and possibly one or two other files that was 
only in packages-win.  They added them to packages-unix, and I think I saw 
another bug where they added it to packages-mac as well, so this may be fixed in 
today's builds.

Comment 7

19 years ago
cc'ing Samir. Samir, any input?
(Assignee)

Comment 8

19 years ago
Yes, the urlbarhistory.shlb/.xpt file are now in the build so this should be 
resolved.
(Reporter)

Comment 9

19 years ago
installed build 2000060108- is opening with default opening page for both 
migrated and new profiles - think this is  fixed
(Assignee)

Comment 10

19 years ago
OK, taking and marking resolved/fixed.
Assignee: jj → sgehani
Status: ASSIGNED → NEW
(Assignee)

Comment 11

19 years ago
Grace, feel free to verify it.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

19 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.