Firefox 3B1: title tooltips persist and are displayed in inappropriate places

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Tony Green, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

When the pointer is hovered over an image which has a "title" tag, the title tooltip appears correctly. But if the pointer is moved to any other page element that has no title assigned, the title previously displayed as a tooltip. This is only reset when the pointer hovers over another element with a title. That tooltip is then displayed over everything else. This behaviour even persists across tabs, so I am actually seeing tooltips from the page in another tab while I type this.

Reproducible: Always

Steps to Reproduce:
1.Visit http://www.suffolkcamra.co.uk/pubs/
2. Hover pointer over the picture of a pink pub in the top-left corner.
3. Title text "Click here to return to the front page" appears as a tooltip.
4. Hover pointer over any paragraph on the page or on the picture below the "pick a town or village" drop-down.
5. "Click here to return to the front page" appears as a tooltip.
6. Hover pointer over one of the small flag icons.
7. Foreign language tooltip appears.
8. Repeat step 4.
9. The same foreign language tooltip appears.
Actual Results:  
Inappropriate tooltip appears

Expected Results:  
No tooltip should appear over a page element without a "title" tag.

Comment 1

11 years ago
Works for me,  Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

Does it work if you create a new profile?  (note that you don't need to
delete your current profile to do this test) --
see http://kb.mozillazine.org/Profile_Manager
(Reporter)

Comment 2

11 years ago
Interesting. Under the new profile it works as expected rather than suffering the wrong behaviour.

I wonder what's in the old profile that might be causing this?

Comment 3

11 years ago
Do you have any extensions or custom themes installed?  If so, try disabling
them temporarily (and restart Firefox) and see if that helps.
(Tools->Add-ons)
(Reporter)

Comment 4

11 years ago
Good spot Mats. The problem is caused by the McAfee SiteAdvisor extension. I'll see about raising a bug with them for this.

I can see here how extensions must be a real pain for the core developers when they cause problems that get bugs raised. Thanks for your help.

Comment 5

11 years ago
Resolving as invalid, since this is not Firefox's fault.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.