"Allow Pages to choose their own colors" options does not work when unchecked

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: anandbal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

I' on Windows XP Sp2, 
In firefox 3 beta 1, Go to Tools->Options
Click the Colors button and uncheck the "Allow pages to use own colors" checkbox
Also click on use System Colors.

I usually set the background to a lighter shade to go easy on my eyes, but several sites still show up with a bright white background.

Some sites are 

www.google.co.in
mail.google.com
http://in.rediff.com/

There are several others. Feel free to contact me if you need more details.


Reproducible: Always

Steps to Reproduce:
1.In the Options->Content tab, click on colors button
2.Uncheck the "Allow poages to use their own colors" checkbox
3.check the "USe System Colors" checkbox

Configure your system default window background to say a light shade of grey.
Now visit any of the above mentioned sites, you would expect to see a grey background.
Actual Results:  
WebPage background is still bright white

Expected Results:  
Expect to see a grey background

Comment 1

11 years ago
Background Images are not being disabled, and system colors are not being used even when the use system colors check box is checked.  My eyes are very light sensitive & I need these disabled in order to avoid migraines.  

eBay is another site example - the initial results list is fine but click on any item and WHAM bright white background slams you in the retinas.  

My pc info:

Firefox 3.0b1
Win XP Pro sp2 (32 bit OS w/64bit capable CPU)

Tried:
1.  Refreshing page after choosing my colors and un-checking the "Allow pages to choose their own colors" option.
2.  Also checking the "use system colors" option and changing my system colors to match my browser preferences, and then restarting Firefox.
3.  Restarted computer after checking the above selections.  No luck.
4.  Checking the allow pages... option, un-checking use system colors, closing Firefox, reopening Firefox, changing settings back again, closing Firefox again, reopening Firefox, still no luck. 
5.  Tried checking only "use system colors" and still no luck.  Restarted again.  The pages remain unbearably white....

PLEASE PLEASE PRETTY PLEASE WITH SUGAR ON TOP fix this because other than this very huge setback I'm totally loving Firefox 3 so far!  :D.  Thank you!
I've also seen this problem in a few different versions of Firefox 3 running on gnu/linux (kubuntu distros). 

Currently I'm using 3.08a:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a8) Gecko/2007100619 GranParadiso/3.0a8

This is an old, Netscape-era bug that I'm very disapointed to see popping back up again.  

To repro: 
Edit-Preferences -> Content -> Colors
Set Text to a light color (I suggest light green)
and Background to black.  Do not check the "Allow pages to choose their own" box.  Now go to a web page like this: 

  http://www.shirley08.com/beach_impeach_5.php

What happens is you get the background color you chose (black) 
and the text color they chose (black) for an intriguing black-on-black color scheme. This is stylish, but not recommended for readability. 

By the way, it looks like Bug 418913 is a duplicate report of this problem.

Comment 3

9 years ago
Does this bug exists right now (2 resp. 1 year later) for you? 

If yes, please update your current firefox and system information. If no, mark this bug status as FIXED.


It WORKSFORME with Firefox 3.5.5 on Ubuntu 9.04.
The above url (for "beach_impeach") looks broken now, so I put up a page of my own to test this with (it specifies a black text, but says nothing about the background).  With a light-on-dark colorscheme specified in firefox, you can still read the text here, so this would appear to be fixed:

http://obsidianrook.com/data/black_text_whatever_background.html
(Reporter)

Comment 5

9 years ago
Tested with Firefox 3.5.5. Functionality is working as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.