Starting Mozilla with "-console" and a URL won't work.

RESOLVED DUPLICATE of bug 74303

Status

Core Graveyard
Cmd-line Features
P3
critical
RESOLVED DUPLICATE of bug 74303
18 years ago
9 years ago

People

(Reporter: Taras Tielkes, Assigned: Bill Law)

Tracking

({crash, helpwanted})

Trunk
Future
x86
All
crash, helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Copy of my post to moz.general:

These work:
mozilla -console
mozilla http://myserver/myfile.html

These fail:
mozilla -console http://myserver/myfile.html  // Will go to default page
mozilla http://myserver//myfile.html -console // Will not even start mozilla

I now know that I can specify the URL using the "-url" parameter. However, I 
thing the two examples above should also work. Perpaps the "-url" parameter 
could be the "default" parameter.

Comment 1

18 years ago
Confirming. Same on PC/Linux (though I don't know if `-console' has any effect
there) with build 2000052109. For the crash on startup with certain args,
here's the stack on linux:

(gdb) set args http://www.mozilla.org -console
(gdb) prun
Breakpoint 1 at 0x804d655
0x804d655 in main ()
nNCL: registering deferred (0)
Usage: apprunner <url>
        <url>:  a fully defined url string like http:// etc..

Program received signal SIGSEGV, Segmentation fault.

#0  0x406ed07a in XInternAtom () from /usr/X11R6/lib/libX11.so.6
#1  0x4068353e in gdk_atom_intern (atom_name=0x4052c7fa "CLIPBOARD", 
    only_if_exists=0) at gdkproperty.c:46
#2  0x40507a82 in nsClipboard::Init ()
   from components/libwidget_gtk.so
#3  0x40507802 in nsClipboard::nsClipboard ()
   from components/libwidget_gtk.so
#4  0x40517b4d in nsClipboardConstructor ()
   from components/libwidget_gtk.so
#5  0x400b2545 in nsGenericFactory::CreateInstance ()
   from libxpcom.so
#6  0x400b013d in nsComponentManagerImpl::CreateInstance ()
   from libxpcom.so
#7  0x400b7b31 in nsComponentManager::CreateInstance ()
   from libxpcom.so
#8  0x400b87b9 in nsServiceManagerImpl::GetService ()
   from libxpcom.so
#9  0x400b8c01 in nsServiceManagerImpl::GetService ()
   from libxpcom.so
#10 0x400b8ee1 in nsServiceManager::GetService ()
   from libxpcom.so
#11 0x400b800d in nsGetServiceByProgID::operator() ()
   from libxpcom.so
#12 0x400c2a5b in nsCOMPtr_base::assign_from_helper ()
   from libxpcom.so
#13 0x804c0c5 in DoOnShutdown ()
#14 0x804d78c in main ()
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: XP Apps → XP Apps: Cmd-line Features

Comment 2

18 years ago
linux crash is now 45074.

Win32 part of this goes over to bill.
Assignee: don → law

Comment 3

18 years ago
*** Bug 31165 has been marked as a duplicate of this bug. ***
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: helpwanted, nsbeta1-

Comment 5

18 years ago
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future

Comment 6

17 years ago
This bug is ancient ... does anyone see this any more?

Comment 7

17 years ago
Is the "-url" parameter documented anywhere?

mozilla --help does not mention it 
(on Linux build ID 2001111314).  If it's documented
somewhere else, I'll submit a bug on the --help text.

Comment 8

17 years ago
I see this bug

$ uname -a
FreeBSD PII350.home.segment7.net 5.0-CURRENT FreeBSD 5.0-CURRENT #1: Fri Feb 22
00:51:23 PST 2002    
root@PII350.home.segment7.net:/disks/current/obj/disks/current/src/sys/PII350 
i386

$ more cvsco.log | grep checkout
checkout start: Sun Feb 24 11:46:40 PST 2002
checkout finish: Sun Feb 24 11:52:08 PST 2002

stack trace (-g):

Program received signal SIGSEGV, Segmentation fault.
0x28434863 in XInternAtom () from /usr/X11R6/lib/libX11.so.6
(gdb) bt
#0  0x28434863 in XInternAtom () from /usr/X11R6/lib/libX11.so.6
#1  0x283c8a2a in gdk_atom_intern () from /usr/X11R6/lib/libgdk12.so.2
#2  0x287b280c in nsClipboard::Init (this=0x80e0100)
    at /disks/current/moz/mozilla/widget/src/gtk/nsClipboard.cpp:172
#3  0x287b25a1 in nsClipboard::nsClipboard (this=0x80e0100)
    at /disks/current/moz/mozilla/widget/src/gtk/nsClipboard.cpp:92
#4  0x287c02d3 in nsClipboardConstructor (aOuter=0x0, aIID=@0x8052ed0, 
    aResult=0xbfbff828)
    at /disks/current/moz/mozilla/widget/src/gtk/nsWidgetFactory.cpp:78
#5  0x281ef915 in nsGenericFactory::CreateInstance (this=0x80f30c0, 
    aOuter=0x0, aIID=@0x8052ed0, aResult=0xbfbff828)
    at /disks/current/moz/mozilla/xpcom/components/nsGenericFactory.cpp:75
#6  0x281eb90c in nsComponentManagerImpl::CreateInstanceByContractID (
    this=0x809c000, aContractID=0x80533a0 "@mozilla.org/widget/clipboard;1", 
    aDelegate=0x0, aIID=@0x8052ed0, aResult=0xbfbff828)
    at /disks/current/moz/mozilla/xpcom/components/nsComponentManager.cpp:1860
#7  0x281ec385 in nsComponentManagerImpl::GetServiceByContractID (
    this=0x809c000, aContractID=0x80533a0 "@mozilla.org/widget/clipboard;1", 
    aIID=@0x8052ed0, result=0xbfbff894)
    at /disks/current/moz/mozilla/xpcom/components/nsComponentManager.cpp:2251
#8  0x281e8261 in nsGetServiceByContractID::operator() (this=0xbfbff8dc, 
    aIID=@0x8052ed0, aInstancePtr=0xbfbff894)
    at /disks/current/moz/mozilla/xpcom/components/nsComponentManager.cpp:234
#9  0x28235082 in nsCOMPtr_base::assign_from_helper (this=0xbfbff8d8, 
    helper=@0xbfbff8dc, iid=@0x8052ed0)
    at /disks/current/moz/mozilla/xpcom/glue/nsCOMPtr.cpp:80
#10 0x804e7d3 in DoOnShutdown () at ../../dist/include/xpcom/nsCOMPtr.h:553
#11 0x80510a6 in main (argc=1, argv=0xbfbff97c)
    at /disks/current/moz/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1630

Comment 9

17 years ago
I do a clobber and the crash disappears.  FWIW, I didn't specify anything on the
command line, no URL, nothing, but a clean tree fixed the problem.
Keywords: crash
OS: Windows NT → All

Comment 10

17 years ago
I don't know if the crash is still occurring, but the issue described in the
original report is in bug 74303

Comment 11

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical
I was able to start Mozilla with mozilla -console -P tinder http://...

Perhaps this is fixed.
this command works:

./netscape -console -P test-a http://www.kith.org

however, this one doesn't:

./netscape -console http://www.kith.org

in the second test, the default home page loads, instead of the specified URL. 

Comment 14

16 years ago
that's bug 74303

Comment 15

15 years ago
I see now that the crash got split off as bug 45074, which is now fixed.

marking dupe of "commandline URL ignored in combination with certain arguments"

*** This bug has been marked as a duplicate of 74303 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 74303
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.