non-zero letter-spacing is cause of failing to compute shrink-to-fit width

VERIFIED FIXED in mozilla1.9beta2

Status

()

Core
Layout: Block and Inline
P3
normal
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: masayuki, Assigned: roc)

Tracking

({regression})

Trunk
mozilla1.9beta2
x86
Windows Vista
regression
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Created attachment 289698 [details]
testcase

See the testcase and hover the mouse cursor to "abcdef". Then, "abcdef" has outline, so they are reflowed.However, sometimes an "abcdef" is gone to next line even if there is an enough space. This is not a recent regression. But I think this bug was not on Gecko1.8.
Flags: blocking1.9?
Created attachment 289699 [details]
screenshot
Assignee: nobody → roc

Comment 2

11 years ago
I can't reproduce that on OS X (tried with almost all fonts available).
Created attachment 289817 [details]
another screenshot

There are gaps before the span elements.

Comment 4

11 years ago
DBaron/Roc any ideas on severity here?
I reproduced it. It's pretty weird so I think it should block.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
Created attachment 290495 [details] [diff] [review]
fix

Ugh, this is simply an uninitialized variable read when gfxFont::Measure is called with aStart == aEnd.
Attachment #290495 - Flags: review?(pavlov)
Whiteboard: [needs review]

Updated

11 years ago
Attachment #290495 - Flags: review?(pavlov) → review+
checked in
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs review]
backed out due to Linux Ts regression
Relanded.

Checking in gfx/thebes/src/gfxFont.cpp;
/cvsroot/mozilla/gfx/thebes/src/gfxFont.cpp,v  <--  gfxFont.cpp
new revision: 1.77; previous revision: 1.76
done
Target Milestone: --- → mozilla1.9 M10
-> v. (2007120205-trunk/WinXP)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.