horizontal scrollbar is not displayed because of body { overflow-x: hidden }

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
10 years ago
7 years ago

People

(Reporter: t0rus, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

on that page (possibly some others) the horizontal scroll bar is not displayed if window is resized so the content doesn't fit, or if zoomed in. it is impossible to get to the hidden content with mouse side scrolling, middle click, or keyboard keys

Reproducible: Always

Steps to Reproduce:
1.go to http://www.rsa.com/rsalabs/node.asp?id=2927
2.zoom in till content doesn't fit on one page horizontally
3.try to scroll sideways
Actual Results:  
content on the page is cut off beyond width of the window

Expected Results:  
a horizontal scroll bar should appear
Confirming with latest trunk on Windows XP.
Blocks: 4821
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → GFX
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
This isn't caused by bug 4821.
Try resizing the window to a small width, you still won't get a horizontal scrollbar.

It happens because the all of the content is wrapped in an overflow: hidden div.
Opera9 does the same as Mozilla.
It seems like a tech evangelism bug.
Yes indeed. Not blocking bug 4821.
No longer blocks: 4821
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard

Comment 4

7 years ago
A workaround for "body { overflow-x:hidden; }" cases (but inapplicable to an all-encompassing overflow:hidden div) is to add to chrome\userContent.css in the profile folder

body { overflow: visible !important }

e.g., http://www.mozilla.org/projects/firefox/prerelease.html
- a Mozilla.org page that abuses overflow:hidden - will have a horizontal scrollbar on 800x600-pixel desktops and on larger desktops when zoomed in, and the HTML body element will not suffer from Bug 386444.

Bug 509277 is similar to this this.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2pre) Gecko/20100226
Minefield/3.7a2pre

Comment 5

7 years ago
Hi
I have the same problem on Ubuntu 10.04 with Firefox 3.6.3
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: GFX → Layout
Product: Core Graveyard → Core
QA Contact: general → layout
Resolution: --- → INVALID
Summary: horizontal scrollbar is not displayed → horizontal scrollbar is not displayed because of body { overflow-x: hidden }
You need to log in before you can comment on or make changes to this bug.