Last Comment Bug 404837 - Browsing history retained too long
: Browsing history retained too long
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 332748
  Show dependency treegraph
 
Reported: 2007-11-21 11:55 PST by Bradley Hook
Modified: 2007-11-25 19:19 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bradley Hook 2007-11-21 11:55:11 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

The default number of days in FF3b1 seems to be 180 days (upon creating a new profile). This is drastically different from previous versions and other browsers.

Reproducible: Always

Steps to Reproduce:
1. Create a new profile
2. Check the privacy settings
3.
Actual Results:  
180 days is the default

Expected Results:  
Should be more reasonable and consistent with older versions and other browsers, around 20 days.
Comment 1 Jesse Ruderman 2007-11-21 15:44:27 PST
The change to 180 days was intentional.  See bug 332748 (note that its summary has changed several times) and bug 402880.
Comment 2 Ryan VanderMeulen [:RyanVM] 2007-11-21 15:49:45 PST
It's a feature of the new SQL-driven history system which allows for much longer histories without any performance degradation like Fx2 would have had. Combined with the vast location bar search improvements, it's actually very useful. Obviously, if you feel otherwise, you can always change it back yourself, but given how it got to be where it is today, I don't think you're going to see the value reduced.

INVALID?
Comment 3 (not reading, please use seth@sspitzer.org instead) 2007-11-21 16:02:49 PST
invalid, or a duplicate of bug #332748, at least in one version, where we questioned if 180 days was too long.


*** This bug has been marked as a duplicate of bug 332748 ***
Comment 4 Jesse Ruderman 2007-11-21 17:04:03 PST
Bug 332748 had many different, almost opposite, meanings.  Let's not dup things like this to it; it makes it hard to keep track of what issues are being reported frequently.  Instead, let's mark this as WONTFIX and let it collect its own dups (if any).

Note You need to log in before you can comment on or make changes to this bug.