All users were logged out of Bugzilla on October 13th, 2018

Patch to catch bytecode generated by javascript compiler

RESOLVED FIXED

Status

P3
enhancement
RESOLVED FIXED
19 years ago
19 years ago

People

(Reporter: vajda, Assigned: norrisboyd)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
- added ClassOutput interface
  - added setter/getter on Context and NameHelper (and its implementation).
  - instead of adding parameters in quite a few places, I followed the model
    set by Context.setTargetClassFileName() et al. by adding 
    Context.setClassOutput(). The classOutput gets used when a class is
    produced unless Context.setTargetClassFileName() was called.
(Reporter)

Comment 1

19 years ago
Created attachment 9094 [details] [diff] [review]
cvs diff -u
(Reporter)

Comment 2

19 years ago
Created attachment 9095 [details]
Additional ClassOutput.java file (cvs add)
(Reporter)

Comment 3

19 years ago
Created attachment 9096 [details]
An example ScriptCompiler.java file using the new ClassOutput feature
(Assignee)

Comment 4

19 years ago
Reassign to my new account name.
Assignee: norrisboyd → nboyd
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
Looks good. Regression tests pass with this change.

Since it introduces a new API class and we're trying to wrap up 1.5R1, I think 
I'll put this into 1.5R2.

(Assignee)

Comment 6

19 years ago
I finally committed this. Thanks for your contribution!
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.