TD elements don't inherit "font-size" from TABLE in strict mode (with ENABLE_STRICT=true)

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED INVALID
18 years ago
9 years ago

People

(Reporter: Taras Tielkes, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using a strict Doctype (see attachment) that I believe to be correct, it seems 
child TDs dont inherit "font-size" from their parent TABLEs.

Behaviour is seen in normal HTML as well as DOM-constructed HTML.
(Reporter)

Comment 1

18 years ago
Created attachment 9097 [details]
HTML document with strict doctype that shows some examples of TDs not inheriting font-size
DOCTYPE is invalid. It reads: 

   <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN   
   http://www.w3.org/TR/html4/strict.dtd">

...it should read:

   <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"   
   "http://www.w3.org/TR/html4/strict.dtd">

...note the quotes between the FPI and the DTD URI. (FPI = the "-//W3C" bit and
DTD URI = the "http://" bit.)

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
QA Contact: ian → amar
(Reporter)

Comment 5

17 years ago
Verified by reporter.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.