Define behaviour for installing an update that turns out to be a different add-on

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
10 years ago
8 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Presumably not a supported behaviour but it is possible for the update info for an add-on to point to an add-on that is not the original (by error or because the author changed id for some reason)

The current behaviour is that you end up with both original and new add-ons installed (and the installation pane displays the old as "Installing..." and the new as "Restart to complete the installation").

We should probably be either denying the install of the new add-on, or uninstalling the old one.
A way to migrate to another GUID would help because some authors had to change it, some because they haven't changed it after copying the source, others because they started to have different GUIDs for different operating systems and some had to change it because someone else uploaded an extensions with that GUID already at AMO.

I compared the GUIDs of ~400 add-ons in the last month, ca. 10% had changed its GUID in the last years.
I don't think we should make a decision about uninstalling the old GUID or installing the new GUID without an explicit instruction in the update file about what to do in case this happens.

bug 412819 is sortof about that. If we added certain flags to an update file that said something like "on mismatch, do this" and would default to installation failing, it would be better imo.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
(Reporter)

Updated

8 years ago
Duplicate of this bug: 471785
(Reporter)

Comment 4

8 years ago
I think we should just handle this with bug 412819. If the actual cause is just a mistake on the part of the developer then the new add-on and previous one will both exist which is probably better anyway.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.