Onebox instantly crashes before rendering

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Brian Gannon, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
On build 2000052313, mozilla instantly crashes on the above URL.
below is a stacktrace.
This machine is a:
Linux dual 2.2.14 #16 SMP Fri May 19 19:14:22 EDT 2000 i686 unknown



#1  0x40a02f5a in nsDocShell::SetCurScrollPos () from
/home/cmiyc/package/libdocshell.so
#2  0x40a056a5 in nsDocShell::ScrollIfAnchor () from
/home/cmiyc/package/libdocshell.so
#3  0x40a043e1 in nsDocShell::InternalLoad () from
/home/cmiyc/package/libdocshell.so
#4  0x40a018c3 in nsDocShell::Reload () from /home/cmiyc/package/libdocshell.so
#5  0x409e6aeb in nsWebShell::ReloadDocument () from
/home/cmiyc/package/libraptorwebwidget.so
#6  0x4057e1c3 in NSGetModule () from
/home/cmiyc/package/components/libchardet.so
#7  0x4057f92b in NSGetModule () from
/home/cmiyc/package/components/libchardet.so
#8  0x4057f447 in NSGetModule () from
/home/cmiyc/package/components/libchardet.so
#9  0x41029e70 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#10 0x4007fe38 in nsDeque::FirstThat () from /home/cmiyc/package/libxpcom.so
#11 0x40febf60 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#12 0x40fec36f in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#13 0x40ff3c12 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#14 0x40ff4443 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#15 0x40ff3310 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#16 0x40ff2d22 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#17 0x41003d43 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#18 0x41003b85 in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#19 0x410044ac in NSGetModule () from
/home/cmiyc/package/components/libraptorhtmlpars.so
#20 0x40a160fb in NSGetModule () from
/home/cmiyc/package/components/liburiloader.so
#21 0x409513a9 in NSGetModule () from /home/cmiyc/package/components/libnecko.so

Comment 1

18 years ago
hmm there were several problems around that build - does it still happen?
I couldn't repeat the crash with 2000-052408 M16 Linux but this is a single CPU box.
(Reporter)

Comment 2

18 years ago
Works for me.. Just got this mornings build 2000052408
Sorry for the trouble
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Not at all.. thanks for the report!



And there are oddities with that page: the editor field in the page i spawned

new window from died after i had clicked a few links on onebox. But i think that

may be a known bug - there's been a few editor bugs of type "can't type in..."

lately.

(Assignee)

Comment 4

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 5

18 years ago
Adding crash keyword
Keywords: crash

Comment 6

18 years ago
Verified WORKSFORME with build 2000071708 on Linux 2.2.16.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.