Firefox 3 Beta 1 doesn't start on 10.3.9 due to unresolved symbols

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Dan Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/312.9 (KHTML, like Gecko) Safari/312.6
Build Identifier: 

$ Desktop/Firefox.app/Contents/MacOS/firefox-bin   
dyld: Desktop/Firefox.app/Contents/MacOS/firefox-bin Undefined symbols:
/Users/meg/Desktop/Firefox.app/Contents/MacOS/XUL undefined reference to _kCGColorSpaceGenericRGB expected to be defined in Carbon
/Users/meg/Desktop/Firefox.app/Contents/MacOS/XUL undefined reference to _kCGImageSourceShouldAllowFloat expected to be defined in Carbon
/Users/meg/Desktop/Firefox.app/Contents/MacOS/XUL undefined reference to _kCGImageSourceTypeIdentifierHint expected to be defined in Carbon
Trace/BPT trap

Double-clicking does not launch the app of course.  OS X 10.3.9 PPC Build #7W98

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Looks like at least kCGColorSpaceGenericRGB is 10.4 and later only.
(Reporter)

Comment 2

11 years ago
Looks like all of them are >= 10.4 only

Comment 3

11 years ago
OS X 10.3 is not supported in Firefox 3:
http://www.mozilla.com/en-US/firefox/system-requirements-v3.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 4

11 years ago
Fair enough, but a release note saying a platform isn't supported isn't enough to close this bug. There should be an error message either in the installer or on startup. I've had a search for a bug about that but I can't find one - do you know if there is one or should I file a new one?

Updated

10 years ago
Duplicate of this bug: 432261
Duplicate of this bug: 433138

Comment 7

10 years ago
I agree -- why do so many Mac OS X installers allow you to install a >= 10.4 app on a 10.3.9 system...  only to then crash immediately on startup.  Ugh, time to upgrade, I guess.  BUT STILL!  There should be some warning system in place.
Duplicate of this bug: 440735
You need to log in before you can comment on or make changes to this bug.