Memory usage increases over time from 60,000kb at Startup till 103,364kb

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Naoko Kensaku, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-01)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

Memory usage starts to increase every few hours. At 9AM for instance, my memory usage was around 80k, then at 11am it was 90k (I attributed this to a flash site I was opening), which was closed later and now at 12.31pm (my time) the memory is at 103.5k. 

The same thing happened after lunch, when I closed the browser around 12.45pm and then went out for lunch around 1pm. Came back an hour later and memory was again at 103.5k thereabouts. 

The only thing I did was to keep GMail, Livejournal, Meebo and Google Docs open. The rest were opened and closed on an as-and-when basis. 

Reproducible: Always

Steps to Reproduce:
1. Start Firefox as per normal. When running and browsing, open task manager. Note memory usage. 
2. Reopen task manager about an hour or so after the first time. 
3. Rinse, repeat. 
Actual Results:  
Memory usage kept increasing and eventually slowed down the PC's performance. Was unable to use Opera and switching from one window to another had a one, two second lag instead of being instant. 

Expected Results:  
Memory usage should not have increased and I should still be able to swap windows after a few hours. 

Default theme used. I also have these plugins installed, but all but Chatzilla have been updated. They are: 

- IE Tab
- Video Download
- Brit. English Dictionary. Thanks.
(Reporter)

Updated

10 years ago
Summary: Memory usage increases over time from 60M at Startup till 103,364kb → Memory usage increases over time from 60,000kb at Startup till 103,364kb

Comment 1

10 years ago
does it happen when you run FF on it's own ?

and the sites that you visited, is it under this list : http://wiki.mozilla.org/LeakingPages.

If possible remove all the plugins you have installed, and report back.
(Reporter)

Comment 2

10 years ago
> does it happen when you run FF on it's own ?
I am running MSN Messenger 7.5, Thunderbird version 2.0.0.9 (20071031), BitDefender 10 (Corporate), Winamp 5.5, Avira. As and when Programs run: MS Word 03, MS Paint. 

> and the sites that you visited, is it under this list :
> http://wiki.mozilla.org/LeakingPages.
No. 

Comment 3

10 years ago
(In reply to comment #2)
> > does it happen when you run FF on it's own ?
> I am running MSN Messenger 7.5, Thunderbird version 2.0.0.9 (20071031),
> BitDefender 10 (Corporate), Winamp 5.5, Avira. As and when Programs run: MS
> Word 03, MS Paint. 
> 


Could you just run FF on it's own and see if it happens ?

Comment 4

10 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > > does it happen when you run FF on it's own ?
> > I am running MSN Messenger 7.5, Thunderbird version 2.0.0.9 (20071031),
> > BitDefender 10 (Corporate), Winamp 5.5, Avira. As and when Programs run: MS
> > Word 03, MS Paint. 
> > 
> 
> 
 Could you just run FF on it's own and see if it happens ?

one more thing, please remove all add-on. before doing the above.

(Reporter)

Comment 5

10 years ago
>  Could you just run FF on it's own and see if it happens ?
> 
> one more thing, please remove all add-on. before doing the above.
> 

Will do so after work and reply in about... 3 Days time?

Comment 6

10 years ago
how much total ram do you have?
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> how much total ram do you have?
384MB. Srry for the late reply. 

(Reporter)

Comment 8

10 years ago
I ran just Firefox 3 alone while I was out of the office last night. When I came back to it this morning, FF was running at about 20k, and there was no open tabs, just an empty one. 
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
> I ran just Firefox 3 alone while I was out of the office last night. When I
> came back to it this morning, FF was running at about 20k, and there was no
> open tabs, just an empty one. 
> 

Been a few days now, anyone have any solutions to this? I've not changed anything of FF, but usage has increased to 116,205 kb.

Comment 10

10 years ago
384MB is on the poor side to run XP with a browser taking even 60MB. 
But that's not the issue.

1. Do you still see this using firefox 3 final?
2. If so, what URL's?
Component: OS Integration → General
QA Contact: os.integration → general
Whiteboard: closeme 2008-08-01
(Reporter)

Comment 11

10 years ago
No, I don't see it anymore since FF3 final. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 12

10 years ago
I believe this bug should be marked WFM instead since the patch responsible for fixing this is not known.

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.