All users were logged out of Bugzilla on October 13th, 2018

keyboard focus remains in textbox on previous tab when switching tabs with keyboard

RESOLVED DUPLICATE of bug 318881

Status

()

--
minor
RESOLVED DUPLICATE of bug 318881
11 years ago
9 years ago

People

(Reporter: adam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

If I am using a form page on tab 2 and another form (e.g. gmail) on tab 1, then click in a text box on tab 2 to type something, when I switch using keyboard to tab 1 (by pressing CMD-1) and then start to type, the focus is still in tab 2. so no text appears in the text box on tab 1 (which is visible), however if I switch back to tab 2 (which was invisible) I can see the text I was just typing.

Reproducible: Always

Steps to Reproduce:
1. load a form in a tab, focus in a textbox
2. load another form in another tab, focus in a textbox
3. switch from one to another using hotkey (e.g. CMD-2 to go to tab 2)
4. type.
Actual Results:  
nothing appears on screen, data is entered in previously active tab


Expected Results:  
data typed should appear in visible text box on currently active tab

workaround - click in the textbox again to force focus to return

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318881
You need to log in before you can comment on or make changes to this bug.