form onsubmit fires twice and crashes browser when using keyboard to submit form

RESOLVED DUPLICATE of bug 401425

Status

()

Core
General
--
major
RESOLVED DUPLICATE of bug 401425
10 years ago
10 years ago

People

(Reporter: Jake Olefsky, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Visit the URL to see a reduced testcase.  When a form has a javascript onsubmit handler and you hit 'return' to submit the form, the handler will fire twice and then the browser will crash. 

If you click the submit button instead of hitting 'return' it will work correctly.

I am using Firefox 3b1 on Mac OS X 10.5.1 (Leopard)
(Reporter)

Comment 1

10 years ago
I just tested this on a PC and could not get it to misbehave, so it must be a Mac only bug.  Therefor, I am switching the Component to "OS Integration".
Component: Form Manager → OS Integration
QA Contact: form.manager → os.integration

Comment 2

10 years ago
i can confirm this on mac also. i dont get the crash, but the forms get submitted twice. reproducible everytime...


running os x 10.4.11 with firefox 3b1.
Jake and yoav: I don't see this using the latest nightly on mac,  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007113004 Minefield/3.0b2pre. Can you try the latest nightly? I believe Bug 401425 was the issue here.
The bug Marcia mentioned certainly seems likely to have caused the "fired twice" problem. If it did fix this, I hope it fixed the crashing part too :/
Component: OS Integration → General
Product: Firefox → Core
QA Contact: os.integration → general
(Reporter)

Comment 5

10 years ago
Either that bug was what caused it, or something else was fixed, because it is no longer an issue with b3. I will close this bug now.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 401425
You need to log in before you can comment on or make changes to this bug.