'Newest' RSS feed broken/empty

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
11 years ago
2 years ago

People

(Reporter: aryx, Assigned: wenzel)

Tracking

Details

(URL)

Attachments

(1 attachment)

The newest RSS feed linked on the add-ons pages is empty.

Example: 'Newest' RSS feed broken
(Assignee)

Comment 1

11 years ago
Created attachment 290272 [details] [diff] [review]
fixing addon status array for "newest" RSS feed

Oh, this is a bug introduced through the fix to bug 394394. Thanks for filing this.

Anyway, the "public" status passed into the model is not an array so implode() failed. The "arrayification" was already present, just in the wrong spot. Laura, please review. Thanks!
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #290272 - Flags: review?(laura)

Comment 2

11 years ago
Comment on attachment 290272 [details] [diff] [review]
fixing addon status array for "newest" RSS feed

Looks virtuous to me.
Attachment #290272 - Flags: review+
(Assignee)

Comment 3

11 years ago
Fixed in SVN r8301. Thanks, all.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: push-needed
Resolution: --- → FIXED

Updated

11 years ago
Keywords: push-needed
(Assignee)

Updated

10 years ago
Attachment #290272 - Flags: review?(laura)
Verified FIXED on https://addons.mozilla.org/en-US/firefox/browse/type:1/cat:all/format:rss?sort=newest.
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: PC → All
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.