Closed Bug 405305 Opened 12 years ago Closed 12 years ago

input (checkbox) inaccessible using mouse when inside legend, can access with tab key

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: tarwin, Assigned: roc)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4; .NET CLR 2.0.50727) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Firefox 3.0b1 (shown as string "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4; .NET CLR 2.0.50727) Gecko/20070515 Firefox/2.0.0.4")

On the example page, which is created using Javascript via ExtJS (www.extjs.com), the input field (next to the words "User Information") are inaccessible using the mouse (you cannot click on it). In other browsers (including Firefox 2.0.0.7 it works perfectly).

During trying to test what this problem could be I also ran into another problem. When I disabled Javascript under tools>options Javascript was still enabled for the page until I refreshed it, which made it impossible to check if it was some strange conflict with ExtJS.

Saving the HTML created by the Javascipt to a local HTML file and loading it meant I could click on the input box (although all Javascript was of course broken).

Reproducible: Always

Steps to Reproduce:
1. Load http://extjs.com/deploy/dev/examples/form/dynamic.html in Firefox 3.0b1
2. Try to click on the checkbox next to the words "User Information"
3. Nothing happens.
Actual Results:  
Nothing.

Expected Results:  
The checkbox is "checked". (Also, the form expands, but this is not a problem that Firefox is causing).
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Layout regression
Assignee: nobody → roc
Flags: blocking1.9?
Attached file testcase
It seems like every left floating element inside a legend isn't focusable by mouse.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Attached patch fixSplinter Review
Simple fix. It's really just a one-liner. Since the legend is a block, its background needs to go on the BlockBorderBackground list, not the inline-content list.
Attachment #290823 - Flags: superreview?(mats.palmgren)
Attachment #290823 - Flags: review?(mats.palmgren)
Whiteboard: [needs review]
Comment on attachment 290823 [details] [diff] [review]
fix

>+++ mozilla-trunk/layout/reftests/bugs/405305-1-ref.html
>+<fieldset>

>+++ mozilla-trunk/layout/reftests/bugs/405305-1.html
>+<fieldset border="0">

This difference is unintentional?

r+sr=mats
Attachment #290823 - Flags: superreview?(mats.palmgren)
Attachment #290823 - Flags: superreview+
Attachment #290823 - Flags: review?(mats.palmgren)
Attachment #290823 - Flags: review+
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [needs review]
Version: unspecified → Trunk
yeah, I'll fix that. it has no effect anyway.
checked in
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Verified fixed with the testcase, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120405 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
Blocks: 386752
You need to log in before you can comment on or make changes to this bug.