Support "out of order" multiple word tag search in url bar autocomplete

VERIFIED FIXED in Firefox 3 beta4

Status

()

P3
normal
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: moco, Assigned: Mardak)

Tracking

Trunk
Firefox 3 beta4
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 401660])

Attachments

(1 attachment)

support "out of order" multiple word tag search in the url bar and in the places organizer.

in bug #401869, ronin.achilles@gmail.com writes:

"aren't we going to allow random ordering of words? i.e. if a user has a tag called "read later"... will he not be able to search on "read later" as well as "later read"?

right now, this doesn't work.  

note, one way we could implement this would be to change                                                                               nsNavHistory::CreateTermsFromTokens() to generate all the permutations, and not just the "in order" ones.  

that would lower our "limit" (caused by SQLITE_MAX_EXPR_DEPTH), but that might be acceptable.

Updated

11 years ago
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
(Assignee)

Comment 1

11 years ago
The autocomplete results part will be fixed by bug 401660.
Depends on: 401660
Priority: -- → P3
Target Milestone: --- → Firefox 3 beta4
(Assignee)

Comment 2

11 years ago
Created attachment 304850 [details] [diff] [review]
testcase v1

I'll land this testcase when bug 401660 is fixed.
(Assignee)

Comment 3

11 years ago
Should I spin off a separate bug for library/places organizer searching if bug 401660 lands and mark this fixed?
(Assignee)

Updated

11 years ago
Assignee: nobody → edilee
Component: Places → Location Bar and Autocomplete
QA Contact: places → location.bar
Whiteboard: [has fix in bug 401660]
(Assignee)

Updated

11 years ago
Blocks: 419366
(Assignee)

Comment 4

11 years ago
Checking in toolkit/components/places/tests/unit/test_history_autocomplete_tags.js;
/cvsroot/mozilla/toolkit/components/places/tests/unit/test_history_autocomplete_tags.js,v  <--  test_history_autocomplete_tags.js
new revision: 1.4; previous revision: 1.3
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre and the same nightly on Win XP
Status: RESOLVED → VERIFIED
(Assignee)

Updated

11 years ago
Summary: support "out of order" multiple word tag search in the url bar and in the places organizer → Support "out of order" multiple word tag search in url bar autocomplete
You need to log in before you can comment on or make changes to this bug.