Assert in Places - Recent tags-subfolder

RESOLVED DUPLICATE of bug 404758

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 404758
10 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112505 Minefield/3.0b2pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112505 Minefield/3.0b2pre Firefox/3.0

Click on the Places folder on the bookmarks toolbar. 
Click on either of the 'tags' in the list (Recent or Most visited)
Hover over the tag used sub-folder 
Right-click - note assert: 

ASSERT: Node QI Failed
Stack Trace: 
0:QI_node([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)],nsINavHistoryQueryResultNode)
1:asQuery([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)])
2:PU_getURLsForContainerNode([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)])
3:PC_buildContextMenu([object XULElement])
4:buildContextMenu([object XULElement])
5:onpopupshowing([object MouseEvent])

Clicking OK then closes the Places Folder droplist, and leaves a hanging context menu, but it can be closed by clicking outside the context menu box.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Vista HP, todays build

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112505 Minefield/3.0b2pre Firefox/3.0 ID:2007112505
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404758
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.