[trunk] Java applet crashes firefox/windows, hangs firefox/linux

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: wsheets, Unassigned)

Tracking

({crash})

3.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112506 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112506 Minefield/3.0b2pre

[firefox-trunk] This java applet crashes firefox on windows and hangs forever on
firefox-linux while using 100% cpu.  Same applet works fine with latest Release.

I gave a URL for the jarfile because you need a trading account with the online
brokerage OptionsXpress.com to run the applet in firefox.  The applet draws
stock and commodity price charts.  (You can open an account for free if you
want to.)

Reproducible: Always

Steps to Reproduce:
1. Login at optionsxpress.com and click on the link "Try our Streaming Beta
   Flex Charts"
2.
3.
Actual Results:  
On windows, firefox crashes immediately.  I've filed several talkback reports
already.  On linux, firefox hangs forever while chewing up all the cpu.


Their older, stable version of java charts works fine on firefox-trunk, and
their beta version works fine on firefox-release.
You report a bug about Java but you didn't include the used Java Plugin Version (see "about:plugins" as URL)
(Reporter)

Comment 2

11 years ago
On linux I tried both 1.5.0.13 and 1.6.0.03, and on Windows I tried
the latest 1.6.x (all from Sun.com).  Made no difference.
(Reporter)

Comment 3

11 years ago
Some commit made in the last three days has fixed the linux problem -- this java
applet now works perfectly.  Unfortunately the Windows firefox-trunk still crashes when starting the same applet.  Several more recent talkback reports are
on file.

I'm thinking that this may be two separate bugs triggered by one applet(?)
(Reporter)

Comment 4

11 years ago
Here's an applet that fails to load 100% of the time in firefox-trunk on linux:
http://wwwghcc.nsstc.nasa.gov/GOES/
Click on any of the 'Water Vapor' links on the right.  Now click on 'Animate Image Above'.  This causes a java.lang.interruptedException every time on linux.
Sun Java 1.6.0.05.  Something is badly broken wrt java in trunk.

Comment 5

11 years ago
Confirm crash with http://wwwghcc.nsstc.nasa.gov/GOES/ applet

Windows Server 2008 x86
Firefox 3 RC1
Java Plugin: 1.6.0.06

(Page loads but, as soon as Java starts, firefox crashes
(Reporter)

Comment 6

10 years ago
Guys, this bug affects Firefox 3 RC2 also, so someone had better jump on
this soon.
Severity: critical → blocker
Keywords: crash, topcrash
Version: unspecified → 3.0 Branch
This is no topcrash and it's of courser no blocker.

Before someone "jump on" this you have to attach a human readable stack trace and such Java bugs are in 90% bugs in the plugin itself which would make this bug report invalid.

For a hang on linux you have to attach a debugger on a build with symbols, for a crash use the buildin crahsreporter, send the report and post the crash from about:crashes.
Severity: blocker → critical
Keywords: topcrash
(Reporter)

Comment 8

10 years ago
I just tried RC3 on Windows and it no longer crashes, which is great.
However, the nasa.gov site in comment 4 still hangs 100% of the time
on linux with java 1.6.  Can you confirm or deny, please?
(Reporter)

Comment 9

10 years ago
Well, you're right.  I just tried the latest jdk snapshot build from Sun
and the GOES website works normally again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.