Categories lost on ICS file import

VERIFIED DUPLICATE of bug 316927

Status

VERIFIED DUPLICATE of bug 316927
11 years ago
10 years ago

People

(Reporter: davofanmail, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: lightning 0.7 on Thunderbird 2.0.x with Penelope 0.21a (Eudora 8a)

Lightning/Tbird running fine on my system.
Import ICS file with categories set for most events.  Although categories pre-existed in Lightning, none of the category attributes survived the import.


Reproducible: Always

Steps to Reproduce:
1. Start Lightning, configure it with categories
2. Import ICS file with category flags set for many events
3.
Actual Results:  
Category flags do not make it into the Lightning calendar via import

Expected Results:  
Import works and properly sets category flags for all meetings.

Windows XP-SP2 with all the latest stuff.  Thinkpad hardware.

Comment 1

11 years ago
You have to create the same categories to see them again.
Importing events with a category attached will not add them automatically to the categories list in Lightning/Sunbird preferences.

But the category should be still set on the imported events. Please edit some sample events to check if the category is still set.
(Reporter)

Comment 3

11 years ago
I didn't communicate clearly.  
I pre-created the list of categories in Lightning, using the preferences editor.
I spelled all the categories the same as the categories that I knew would be coming in via import.
When the import was done, none of the category attributes were attached to any of the appointments (using the editor in Lightning, they *could be* set after import, but they weren't properly set during the import process).
Component: General → Import and Export
OS: Windows XP → All
QA Contact: general → import-export
Hardware: PC → All

Comment 4

11 years ago
WFM with Tb 2.0.0.9+Lt 0.7+ Penelope 0.1a22 and also with Lt 0.8pre 2008012609
I pre-created the same categories that are included in ics.

Comment 5

11 years ago
LG 0.8 / TB Version 2.0.0.12 (20080213)
Current version accepts "Category" item per event/task. But if the ICS file contains multiple "Category" items (as defined with rfc2445 -- comma separated values) only the last one is hold with the event/task. The other ones are LOST!!

This limits the compatiblity with other rfc2445 compliant calendar apps.
While the other bug is an enhancement, it is indeed the same problem and should be fixed together. I'm adding notes accordingly on the other bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316927

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.