Passwords reappear after being deleted, when using the search

VERIFIED FIXED in mozilla1.9beta3

Status

()

P2
normal
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: hobbsee, Assigned: Ehsan)

Tracking

({regression})

Trunk
mozilla1.9beta3
regression
Points:
---
Bug Flags:
blocking1.9 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007111419 GranParadiso/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007111419 GranParadiso/3.0b1

Based on https://bugzilla.mozilla.org/show_bug.cgi?id=315416

If i remove a few entries from the password manager, then hit "show passwords", the deleted entries show up.  This only happens after using the search first, and then deleting the passwords.

Steps to reproduce:

open the p/w manager
type in a search query.  
pick one of the entries, hit delete.  
it vanishes.  
hit show passwords.  
it comes back.  
either clear the search bar then, and the offending username/password vanishes, or hit "hide passwords", then clear the search bar, and the offending username/password vanishes.

When using signon.debug javascript.options.showInConsole options, nothing abnormal is shown.  It's not profile / extension / etc related.

Reproducible: Always
DeleteSignon() in toolkit/components/passwordmgr/content/passwordManager.js looks suspicious to me. The list it's deleting from is specified by:

|signonsTreeView._filterSet.length ? signonsTreeView._filterSet : signons|
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Version: unspecified → Trunk
(Assignee)

Comment 2

11 years ago
Regression from bug 327048.  Taking over...
Assignee: nobody → ehsan.akhgari
Flags: in-litmus?
Flags: blocking-firefox3?
Keywords: regression
Target Milestone: --- → Firefox 3 M11
(Assignee)

Updated

11 years ago
Blocks: 327048
Status: NEW → ASSIGNED
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
(Assignee)

Comment 3

11 years ago
Created attachment 292322 [details] [diff] [review]
Patch (v1)

The code at <http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/components/passwordmgr/content/passwordManager.js&rev=1.18&mark=121#119> can't be touched, because of the way that the |DeleteSelectedItemFromTree()| function works.

The problem is caused by the fact that if passwords are deleted from a filtered view, the deletions are not made in the original (non-filtered) |signons| table, so when an action on that original table is performed next (such as, clicking Show Passwords) the deleted entries re-appear.

The proposed solution is to reload the |signons| table in |FinalizeSignonDeletions()| if the deletions are performed in a filtered view, so that the two tables stay in sync.

This patch implements the mentioned solution.  It's been tested, and the test case in the comment 0 cannot be reproduced on a trunk build with this patch.
Attachment #292322 - Flags: review?(mconnor)

Updated

11 years ago
Attachment #292322 - Flags: review?(mconnor) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Checking in toolkit/components/passwordmgr/content/passwordManager.js;
/cvsroot/mozilla/toolkit/components/passwordmgr/content/passwordManager.js,v  <--  passwordManager.js
new revision: 1.19; previous revision: 1.18
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Summary: Passwords reappear after being deleted, when using the search. → Passwords reappear after being deleted, when using the search
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042504 Minefield/3.0pre. https://litmus.mozilla.org/show_test.cgi?id=5294 added to litmus.
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.