error for calUtils.js line 1210, add-ons manager does not open

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112604 Calendar/0.6a1

error for calUtils.js line 1210, add-ons manager does not open

Error: [Exception... "'JavaScript component does not have a method named: "onRemoveAlarmsByItem"' when calling method: [calIAlarmServiceObserver::onRemoveAlarmsByItem]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: file:///F:/Software/Buero/Kalender/Sunbird%20Trunk/js/calUtils.js :: notifyFunc :: line 1207"  data: no]
Source File: file:///F:/Software/Buero/Kalender/Sunbird%20Trunk/js/calUtils.js
Line: 1210
Please provide steps to reproduce the issue. 

I do not see this error using Sunbird 0.6a1 (2007112604) or Sunbird 0.8pre (2007112606). Add-ons manager opens without problems.
Steps to reproduce:
In the default profile (which has also survived many Sunbird updates), launching Sunbird and then calling Tools > Add-ons is sufficient: No add-ons manager, also in safe mode.

In a new profile, I can call the add-ons manager, but there is an error in the console for both profiles:

Error: uncaught exception: [Exception... "Invalid InterfaceID"  nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)"  location: "JS frame :: file:///F:/Software/Buero/Kalender/Sunbird%20Trunk/components/nsInterfaceInfoToIDL.js :: <TOP_LEVEL> :: line 45"  data: no]

Seems like a dupe of bug 395582.
The error in the new profile occurs only at the first launch of the new profile.
I think this can be closed, a lot has changed in alarm code and the only calIAlarmServiceObserver listener I found has that method implemented.

Closing WFM, please reopen if this problem persists.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.