"<!DOCTYPE" added when viewing file of type "text/rtf"

VERIFIED FIXED in M16

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Henrik Gemal, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] [6/15] fix in hand, URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
If you go to:
http://www.enhydra.org/software/documentation/enhydra/WAP@Enhydra.rtf
the first line that gets shown in the browser is:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

This is wrong since that line is not in the file!

The browser should show what's in the file, and nothing else.

Comment 1

18 years ago
This is harish's issue; but's it a corruption problem, so it should be fixed for 
beta2. Also -- fix is in hand.
Assignee: rickg → harishd
Keywords: nsbeta2
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 2

18 years ago
Created attachment 9162 [details] [diff] [review]
Here is the patch
(Assignee)

Updated

18 years ago
Whiteboard: fix in hand
(Assignee)

Comment 3

18 years ago
*** Bug 40536 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
[nsbeta2+] [6/15]
Whiteboard: fix in hand → [nsbeta2+] [6/15] fix in hand

Updated

18 years ago
Blocks: 40982
(Assignee)

Comment 5

18 years ago
Created attachment 9511 [details] [diff] [review]
A better patch
(Assignee)

Comment 6

18 years ago
Created attachment 9703 [details] [diff] [review]
Yet another patch!!!!!!!
(Assignee)

Comment 7

18 years ago
Moved default DOCTYPE to the HTML DTD. FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
Verified on build 2000061220 on Win2k
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.