AvmDebugMsg eats last output character

VERIFIED FIXED

Status

Tamarin
Virtual Machine
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 290304 [details] [diff] [review]
include \0 in count of bytes passed to StringCbVPrintf()

The vararg version of AvmDebugMsg prints one character less than was specified - which is likely to be the trailing \n.

The problem is that StringCbVPrintf() is passed the result of _vscprintf() - but according to the docs, _vscprintf() returns the count excluding the trailing \0, while StringCbVPrintf() expects space for the \0 to be included.

Attaching a patch that fixes the problem.

Updated

11 years ago
Attachment #290304 - Flags: review+
(Assignee)

Comment 1

11 years ago
thanks ed - checked in 237:0161c573f53f
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.