Closed Bug 405597 Opened 12 years ago Closed 12 years ago

Mark All Read (Ctrl+Shift+C) changes view when View-selectbox has focus

Categories

(Thunderbird :: Mail Window Front End, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 279001

People

(Reporter: dronkert, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: 2.0.0.9 (20071031)

Whenever I find it convenient to view only unread messages, I change the view in the View selectbox on the toolbar to "Unread". Then I want to mark them all read and press Ctrl+Shift+C. Very inconveniently, the view then changes to "Custom Views". (But the messages are marked read.)


Reproducible: Always

Steps to Reproduce:
1. Go to folder with unread messages
2. Change view in selectbox, leave focus on selectbox
3. Press action key not intended to change view, eg. Ctrl-Shift-C
4. View is changed according to key (C), independent of modifiers (Ctrl, Shift)

Actual Results:  
View does change, according to pressed key (C) but independent of modifiers (Ctrl, Shift).

Expected Results:  
View should not have changed because I used key modifiers (Ctrl, Shift) to access a different function.

Workaround is not leave focus on the View-selectbox.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279001
You need to log in before you can comment on or make changes to this bug.