attachments are incomplete when downloaded via thunderbird but work when downloaded direct from the web-interface

RESOLVED DUPLICATE of bug 390795

Status

defect
--
major
RESOLVED DUPLICATE of bug 390795
12 years ago
12 years ago

People

(Reporter: mc666, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Version 2.0.0.9 (20071031)

Whe I try to download attachments via Thunderbird, the files are saved incomplete. Movies are missing the last seconds and pictures have a grey bar at the bottom.
When I download the files dircet from the web-interface of Gmail the files are complete and working fine.
It's just like Thunderbird would stop the download process too early and miss the last bits of the files.

Reproducible: Always

Steps to Reproduce:
1. send an email with an attachment from any account to the account used with Thunderbird.
2. download the file direct from account on the web - everything is ok
3. download the file via TB - file is smaller
Actual Results:  
Movies are missing the last seconds and pictures have a grey bar at the bottom. When downloaded via TB only.

Expected Results:  
Download the complete file wihout cutting the last bits off

Everyhing is set to default (never tried anything else), no anti-virus-application is checking Thunderbird, operation system: Windows XP

Have to download files via web and so I wouldn't need Thunderbird anyway.
So this problem should really be solved.
Version: unspecified → 2.0
Gmail IMAP? If so, likely bug 390795.
I can reproduce this with a Courier-IMAP server via SSL in 2.0.0.6, 2.0.0.9, and the latest 2.0.0.12pre nightly (20080122), so it's not just a Gmail IMAP issue.

Testing at the moment with a 363KB image file, though it's been happening with pretty much all attachments. I've disabled all add-ons, message filters and junk mail controls. It also happens with or without IDLE enabled.

Workaround is either to move the message to and then back from another IMAP folder or to restart Thunderbird, both of which trigger a reload of the attachment.

I've enabled the IMAP debug log in Courier, and it looks like TB is sending BODY.PEEK atoms when it first receives the message. Selecting the message in the message list does not trigger any additional requests, and the broken image icon appears. After restarting TB or moving the message as described above, TB instead sends BODYSTRUCTURE and BODY atoms, and the attached image displays correctly. It looks like Courier is sending the entire attachment either way, but TB is only storing the latter parts of the attachment when it uses BODY rather than BODY.PEEK.

I don't know the IMAP protocol well enough to know if any of this is helpful, but I'll attach logs of the top of the requests.
This is on OS X 10.5.1/Intel, btw.

The mail.gmail.com references in the log are because the message was sent from Gmail, but it's a Courier-IMAP server.
I think this is the same as bug 390795 - duping.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390795
You need to log in before you can comment on or make changes to this bug.