Move Show All History to the top of the history list in the menu (bookmarks menu parity)

VERIFIED FIXED in Firefox 3 beta3

Status

()

P4
normal
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: jmjeffery, Assigned: florian)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112705 Minefield/3.0b2pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112705 Minefield/3.0b2pre Firefox/3.0

With the change to add 'Show all History' to the History Menu drop list I note the Show all History is displayed at the bottom of the drop-list.  I think it would be better to place this under the 'Home' putting the 'Show all History' in the same relative postion as the 'Show all Bookmarks', in the Bookmarks Menu drop-list. 

There is also no keyboard 'short-cut' to open the History Organizer.  
I understand that shortcuts are sometimes hard to come by without causing conflicts, so I have no suggestions.  

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Vista HP, latest nightly build:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007112705 Minefield/3.0b2pre Firefox/3.0 ID:2007112705
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
IMO Ctrl+Shift+H can be mapped for "Show all History".

Updated

11 years ago
Component: History → Places
QA Contact: history → places
Summary: Show All History in wrong position in drop list → Move Show All History to the top of the history list in the menu (bookmarks menu parity)
(Reporter)

Updated

11 years ago
Component: Places → History
Keywords: uiwanted

Updated

11 years ago
Flags: blocking-firefox3?
QA Contact: places → history
except on Mac, since that's the sidebar (Cmd+H is Hide on Mac)
Assignee: nobody → florian
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Target Milestone: --- → Firefox 3 M11

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: P2 → P4
(Assignee)

Comment 3

11 years ago
The "Show All History..." item looks at lot like a "Show more" button and then displaying it at the bottom of the list makes sense.  What about moving the "Show All Bookmarks..." item to the bottom of the bookmarks list?

Comment 4

11 years ago
(In reply to comment #3)
> The "Show All History..." item looks at lot like a "Show more" button and then
> displaying it at the bottom of the list makes sense.  What about moving the
> "Show All Bookmarks..." item to the bottom of the bookmarks list?
> 

The problem displaying "Show All Bookmarks" at the bottom is not too practical since if a user has a long list of bookmarks, he'd have to scroll all the way down too reach it. Hence its current location is just fine where all the fixed commands are at the top while the list of bookmarks itself (which could be of variable length) follows from there.
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> if a user has a long list of bookmarks, he'd have to scroll all the way
> down too reach it.

Huh, yeah that would be bad.  I thought the menu was only displaying the first bookmarks.
(Assignee)

Comment 6

11 years ago
Created attachment 292174 [details] [diff] [review]
patch v1

Move the "Show All History..." item and add the Ctrl+shift+H keybinding except on Mac. It would be good to add another key for the Mac case.

With non-english languages Hide and History will probably start with different letters so the problem we have on Mac will not exist (and the reason why this patch doesn't add the key on Mac will be obscure).
Attachment #292174 - Flags: ui-review?(mconnor)
(Assignee)

Updated

11 years ago
Whiteboard: [needs ui-r]
Comment on attachment 292174 [details] [diff] [review]
patch v1

Looks good, r+ui-r+a=mconnor, trivial and straightforward
Attachment #292174 - Flags: ui-review?(mconnor)
Attachment #292174 - Flags: ui-review+
Attachment #292174 - Flags: review+
Attachment #292174 - Flags: approval1.9+
(Reporter)

Updated

11 years ago
Keywords: checkin-needed
Florian has commit access, so he can commit his own patches. :)
Keywords: checkin-needed, uiwanted
OS: Windows Vista → All
Hardware: PC → All
Whiteboard: [needs ui-r] → [has patch][has review][has ui-review][has approval][ready to land]
(Assignee)

Comment 9

11 years ago
Checking in browser/base/content/browser-sets.inc;
/cvsroot/mozilla/browser/base/content/browser-sets.inc,v  <--  browser-sets.inc
new revision: 1.108; previous revision: 1.107
done
Checking in browser/base/content/browser-menubar.inc;
/cvsroot/mozilla/browser/base/content/browser-menubar.inc,v  <--  browser-menubar.inc
new revision: 1.126; previous revision: 1.125
done
Checking in browser/locales/en-US/chrome/browser/browser.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v  <--  browser.dtd
new revision: 1.85; previous revision: 1.84
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][has review][has ui-review][has approval][ready to land]
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008011504 Minefield/3.0b3pre and on the latest Mac nightly. I verified both the position and the functionality of the keyboard shortcut on Windows.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.