"Save as" doesn't reflect a redirected filename change

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
minor
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: carlsagan43, Unassigned)

Tracking

2.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

I have a php script that redirects users to images on my site so that I can keep track of view counts.  The script gives the user a HTTP 302 Redirect to the correct picture. 

However, after I get redirected to the picture, I right click on the picture and select "Save Image As..."

The name of the file that it tries to save is viewpic.php and the mime type is php script rather than "jpeg"  like it should be.  The file name should be "88-image.jpg".  The file name appears as such in the url box, but not when saving the image.

Reproducible: Always

Steps to Reproduce:
1. Go to http://jpgdump.com/viewpic.php?pic=88-image.jpg
2. Right click on picture  and select "Save image as"
3. Save image
Actual Results:  
Saves image as viewpic.php

Expected Results:  
Saved image as 88-image.jpg
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.