Exception on Javascript excanvas drawImage command

RESOLVED DUPLICATE of bug 405584

Status

()

--
major
RESOLVED DUPLICATE of bug 405584
11 years ago
11 years ago

People

(Reporter: stefman2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

The URL stated above gives an exception when you enter "x" in y1 (or any other function of x) and press "plot graphs". This is a brand new problem with the build installed today, and is not present in earlier builds and other browsers.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.zweigmedia.com/RealWorld/functions/funcBug.html
2.Press "Plot Graphs"

Actual Results:  
An Exception will result:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMCanvasRenderingContext2D.drawImage]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: http://www.zweigmedia.com/RealWorld/functions/graphcodebug.js :: drawDecorations :: line 365"  data: no]

Expected Results:  
try the same page on an earlier build of Firefox or on another browser. The Javascript excanvas drawImage method works properly and puts the images of numbers on the axes as tickmarks.

Comment 1

11 years ago
Duplicate of #405584
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405584
You need to log in before you can comment on or make changes to this bug.