TD elements don't inherit "font-size" from TABLE in strict mode (with ENABLE_STRICT=true)

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: taras.tielkes, Assigned: attinasi)

Tracking

({css1, html4})

Trunk
x86
All
css1, html4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using a strict Doctype (see attachment) that I believe to be correct, it seems 
child TDs dont inherit "font-size" from their parent TABLEs.

Behaviour is seen in normal HTML as well as DOM-constructed HTML.

This is a repost of an earlier bug (40489) that had in invalid doctype.
(Reporter)

Comment 1

19 years ago
Created attachment 9139 [details]
HTML with one static table and one dynamic (DOM1) table, both fail to inherit font-size from TABLE to TD
(Reporter)

Comment 2

19 years ago
This document is displayed correctly in Mozilla.

The problem seems to be caused by "ENABLE_STRICT=true" setting on my machine. 
Running mozilla without this env. setting fixes the style.

Adding rickg@netscape.com for StrictDTD.
(Reporter)

Comment 3

19 years ago
Btw, I'm using ENABLE_STRICT=true because it fixes some other bugs that were a 
real pain in my project. One of them is this one:
http://bugzilla.mozilla.org/show_bug.cgi?id=40183
Confirmed. When ENABLE_STRICT is set to true, we stop inheriting the font-size
from the TABLE element to the TD element, just like I would expect to happen
in Quirks mode.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css1, html4
OS: Windows NT → All
(Assignee)

Comment 5

19 years ago
I spoke with Rick G. and there is a bug in the strict DTD that is causing it to 
keep the browser in QuirkMode (!) He has fixed it but it is not checked-in. You 
can get around this in Viewer by selecting the menu item Style | Compatibility 
Mode | Standard and reloading the document. That will force standard mode, 
regardless of the doctype. In this case Mozilla renders it fine. 

It looks like this fix to the strict DTD was checked-in on the 24th of May 
(yesterday) so it should work in the next nightly-build... Can you check it out 
once the build is available?

Taking this bug over to track it.
Assignee: pierre → attinasi
(Reporter)

Comment 6

19 years ago
I just checked the testcase attachment using a 25/5 nightly build. It works.
(BuildID : 20000-52508)

The page renders correctly with "ENABLE_STRICT=true"
The page also renders correctly without "ENABLE_STRICT=true"
(Assignee)

Comment 7

19 years ago
Thanks Taras. I'll go ahead and close it then!
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
Per reporter comments, verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.