Using CSS to display doesn't seem to notice class references

VERIFIED INVALID

Status

()

Core
XML
P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: Sven Heinicke, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
An XML DTD that allows:

	<Email class="me">sven@zen.org</Email>

isn't recognized when refering to this in a CSS as:

	.me { something here }

Comment 1

18 years ago
The 'dot' notation is specific to HTML, but does not apply to generic XML.
For that, you need to use the attribute selector: [class~=value]

http://www.w3.org/TR/REC-CSS2/selector.html#attribute-selectors
http://www.w3.org/TR/REC-CSS2/selector.html#class-html
Marking INVALID.  See previous comment and
http://www.w3.org/TR/REC-CSS2/selector.html#class-html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
verified 'not a bug' (a.k.a. INVALID).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.