KDE allows more diacritics than Thunderbird

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Andy Pepperdine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071102 PCLinuxOS/2.0.0.9-1pclos2007 (2007) Firefox/2.0.0.9
Build Identifier: version 2.0.0.6 (20070902) (PCLinuxOS)

TB 2.0.0.6
PCLinuxOS 2007
UK Keyboard with AltGr key

Under all other applications, there is a full range of dead keys available using AltGr+<key> to represent diacritics to be placed on the following letter. KWrite, KMail, the console, etc. all have an extensive range. Not all of these are usable in TB or Firefox.

For example, <AltGr+'> & a should give â, which it does on TB.
But the circumflex cannot be added to the letter c. I can cut and paste it in from an editor. <AltGr+'> & c gives nothing instead of ĉ.

Note that Suse, PCLinux and Kubuntu all allow these combinations in applications under KDE. But for some reason Ubuntu (Gnome based) also seems deficient.

Reproducible: Always

Steps to Reproduce:
1.Start writing a message
2.Type <AltGr and apostrophe key(')>
3.followed by c
4. Should give ĉ under KDE

Actual Results:  
Nothing instead of a character

Expected Results:  
The letter ĉ

This may be an enhancement, or a bug - I don't know.
I'm not sure if it's possible to even get the necessary data on Mozilla's widget side to add more diacritics. In any case, the burden is on GNOME here.

Note that ensuring that "export GTK_IM_MODULE=xim" is set in some /etc/X11/Xsession.d/ file (like 00x11-common_set-gtk-im) will allow you to define your own custom combinations for diacritics, etc., in GNOME-based programs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
This may well be fixed in Gnome used in Ubuntu 8.10, since the live CD shows all diacritics as expected in Firefox, but I haven't installed it to try Thunderbird yet.

Andy
You need to log in before you can comment on or make changes to this bug.