Paste from ms word gives double spaces lines

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: rdwray, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-05-21)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; FDM)
Build Identifier: SP 2

The paste function does not reproduce text as copied from other programs. Because of the previous problem I submitted about spell checking, I use MS Word to create message and paste them into ThunderBird when I am unsure of spelling. When I copy from Word to message, it double spaces lines.

Reproducible: Always

Steps to Reproduce:
1.copy from MS Word
2.paste into ThunderBird
3.
Actual Results:  
see above

Expected Results:  
Exact representation of what was copied when it is text only. CR/NL should be normal, not double spaced.
Does it happen with other programs too? I think it's the "from-application" who is responsible for what it puts on the clip board. 
Summary: Paste function → Paste from ms word gives double spaces lines
(Reporter)

Comment 2

11 years ago
No. ThunderBird is the only application that responds in this way. I can paste into Notepad or OpenOffice Writer without this issue, although Writer has its' own aspects when handling cr/nl.
Could something like https://bugzilla.mozilla.org/show_bug.cgi?id=458650#c2 be happening when we are pasting from word.

Roger do you still have the issue ?
Component: General → Message Compose Window
QA Contact: general → message-compose
Whiteboard: closeme 2009-05-21
-> Incomplete due to lack of information. Please reopen if the issue still occurs in the latest Thunderbird trunk builds giving reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.