searching for threadbubble returns no results

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: clouserw, Assigned: laura)

Tracking

unspecified

Details

(Reporter)

Description

11 years ago
This problem has been hanging around for a long time.  The last time we were all in MV, we looked into it and never found the cause, but now that we're taking search seriously, we should figure this out.  Search for 'threadbubble' and it returns nothing.  It should return:

https://addons.mozilla.org/en-US/firefox/addon/5326

kthx
(Assignee)

Comment 1

11 years ago
I note that if you search from 
https://addons.mozilla.org/en-US/firefox/search?q=threadbubble&status=4
you get nothing, but if you search from 
https://addons.mozilla.org/en-US/thunderbird/search?q=threadbubble&status=4
it turns up just fine.

The problem is true in reverse for FF extensions (at least the ones I tested) when searching via the Thunderbird pages, compare
https://addons.mozilla.org/en-US/firefox/search?q=blogrovr&status=4
and
https://addons.mozilla.org/en-US/thunderbird/search?q=blogrovr&status=4
for example.

I'll dig further but that should give me a start.
Status: NEW → ASSIGNED
Include as part of the search fixes for AMO v3.4?
Target Milestone: --- → 3.4
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Include as part of the search fixes for AMO v3.4?
> 

I thought you said this was a feature?  (ie. Search for an add-on in one application and only get add-ons for that application).  That would make this bug a wontfix.
Yeah, this actually is a feature. Showing Tb-only extensions as results for a Fx search would be highly confusing, I think.

Also, this would especially alienate SeaMonkey users because their searches would return about a billion add-ons that are marked Firefox only.

Marking WONTFIX but please reopen if I missed anything.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.