window.open fails when invoked from subdomain

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: Klaus Rheinwald, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5-10, 3.0ß1

Using window.open() in a link fails when the web page is served from a subdomain. If the target filename does not contain a blank, instead of a new window being opened, the file is displayed in the original window. When the filename contains a blank, the second parameter is used as the filename instead of the first one. When the same page is accessed through a top-level domain, everything is ok.

This was tested in 2.0.0.5, 2.0.010 and 3.0ß1

Example: 

- Go to http://myjumplog.net
- Click on link '1533' at the top of the right frame.
- A chart will open in a new window
- Close this window
- Click on link '6' at the bottom of the right frame.
- A chart will open in a new window
- Close this window

Repeat the same procedure, this time on http://my.jumplog.net

- For the first link (1533) an error message is returned that files /totals is not found. This is the name of the target window from the second parameter.

Link behind '1533': javascript:void(window.open("ParalogBarChart_Date [Year]_Jumps.png","totals","width=660,height=500,toolbar=no,dependent=yes"))

- For the second link, instead of a new window opening, the chart is displayed in the right frame. 

Link behind '6': javascript:void(window.open("ParalogPieChart_Place.png","totals","width=660,height=500,toolbar=no,dependent=yes"))


Reproducible: Always

Steps to Reproduce:
See Details  
Actual Results:  
See Details  

Expected Results:  
See Details
(Reporter)

Comment 1

11 years ago
Works fine with IE and Opera
(Reporter)

Comment 2

11 years ago
- http://jumplog.net/my (same directory) works neither
- http://my.jumplog.net works on Ubuntu 7.10
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.