Firefox 3 Uninstaler-option "remove my Firefox personal data and customization" should be disabled.

RESOLVED WONTFIX

Status

()

Firefox
Installer
--
enhancement
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Blaz Valentinuzzi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

If you install Firefox 3 beta1 on the machine where Firefox 2 is already installed, Firefox 3 uses personal files from Firefox 2. In my opinion, the option in uninstaller "remove my Firefox personal data and customization" should be disabled. That's because many people would check that option and would loose their personal files also from Firefox 2.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Firefox 2 already installed on the machine.
Resolving -> WONTFIX. If we are going to add new functionality for a future release it needs to be enabled in order for it to receive wide testing otherwise it won't receive the attention needed to make sure it works as designed when we do release. We also went to extra lengths to communicate the implications of selecting this option (which is off by default) by only displaying the information after selecting this option and changing its background color in order to draw attention to it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.