bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Incorrect handling of file with the same name if Open With is used

VERIFIED DUPLICATE of bug 301328

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 301328
11 years ago
10 years ago

People

(Reporter: Robert Wagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

If two files with the same filename are opened using "Open With", Download Manager only contains one entry. That entry points to the first file downloaded, as the second file has it's file name changed. Either it should point to the latest file downloaded or have multiple entries.

Once instance where this is a problem on sites that dynamically generate a PDF from data that may change over time or in response to the user.


Reproducible: Always

Steps to Reproduce:
1. Download a file that causes the open or save dialog to appear
2. Choose "Open With" and click ok
3. Close the application that showed the file
4. Repeat steps 1-3, note the filename that the application opens is different
5. Click "Open" on the single entry for that filename

Actual Results:  
The original file is shown, not the second file downloaded

Expected Results:  
Either two entries in the download manager, one for each file downloaded, or more simply it should open the latest file with that filename downloaded

This will only work if:
- File is the same name
- "Open With" an external application is used
I think this is fixed on trunk - other than the issue of the stored filename not corresponding to the actual file because exthandler renames it due to a duplicate.
Whiteboard: DUPEME?
(Reporter)

Comment 2

11 years ago
Found a way to easily test it:

1) Do a bug search on Bugzilla
2) Click the "CSV" link down the bottom
3) Open using an external app, leave it open
4) Do a different bug search
5) Click the "CSV" link down the bottom
6) Open using an external app, leave it open
7) Click the "Open" link in Download Manager
8) Note that the file opened is is from the first step
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301328
Verified dup
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.